主席树学习小结(POJ 2104)

    在高中的时候就听到过主席树了,感觉非常高端,在寒假的时候 winter homework中有一题是查找区间第K大的树,当时就开始百度这种网上的博客,发现主席树看不懂,因为那个root[i],还有tx[x].l与tx[x].r是什么意思没有搞懂,所以那时候那题用了划分树的思想,最近有幸看到一篇博客,然后博主推荐了一个up主的视屏讲解,最后终于弄懂了。

  

K-th Number
Time Limit: 20000MS Memory Limit: 65536K
Total Submissions: 64247 Accepted: 22601
Case Time Limit: 2000MS

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment. 
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?" 
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000). 
The second line contains n different integer numbers not exceeding 109 by their absolute values --- the array for which the answers should be given. 
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

Hint

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.

Source

Northeastern Europe 2004, Northern Subregion

   划分树模板

#include<cstdio>
#include<cstring>
#include<algorithm>
#define MAXN 100010
using namespace std;
int tree[20][MAXN],b[MAXN],p[20][MAXN];
void build(int l,int r,int dep)
{
	if(l==r) return;
	int mid=(l+r)>>1,same=mid-l+1;
	for(int i=l;i<=r;i++)
	   if(tree[dep][i]<b[mid]) same--;
	int lpos=l,rpos=mid+1;
	for(int i=l;i<=r;i++)
	  {
	  	if(tree[dep][i]<b[mid]) tree[dep+1][lpos++]=tree[dep][i];
	  	else if(tree[dep][i]==b[mid]&&same>0) 
	  	     {
	  	     	tree[dep+1][lpos++]=tree[dep][i];
	  	     	same--;
			 }
		else tree[dep+1][rpos++]=tree[dep][i];
	  p[dep][i]=p[dep][l-1]+lpos-l;
	  } 
	 build(l,mid,dep+1);
	 build(mid+1,r,dep+1); 
} 
int query(int L,int R,int l,int r,int dep,int k)
{
	if(l==r) return tree[dep][l];
	int mid=(L+R)>>1;
	int cnt=p[dep][r]-p[dep][l-1];
	if(cnt>=k)
	  {
	  	int newl=L+p[dep][l-1]-p[dep][L-1],newr=newl+cnt-1;
	  	return query(L,mid,newl,newr,dep+1,k);
	  }
	else
	  {
	  	int newr=r+p[dep][R]-p[dep][r],newl=newr-(r-l-cnt);
	  	return query(mid+1,R,newl,newr,dep+1,k-cnt);
	  }
}
int main(){
    int n,m;
    scanf("%d%d",&n,&m);
    for (int i = 1 ; i <= n; ++i){
        scanf("%d",&tree[0][i]);
        b[i] = tree[0][i];
    }
    sort(b+1,b+1+n);
    build(1,n,0);
    while(m--){
        int nl,nr,k;
        scanf("%d%d%d",&nl,&nr,&k);
        printf("%d\n",query(1,n,nl,nr,0,k));
    }
    return 0;
}

主席树模板

#include<cstdio>
#include<iostream>
#include<cstring>
#include<queue>
#include<cmath>
#include<algorithm>
using namespace std;
const int maxn=1e5+6;
int n,m,cnt,root[maxn],a[maxn],x,y,k;

struct node{
	int l,r,sum;
}T[maxn*40];

vector<int> v;
int getid(int x)
{
	return lower_bound(v.begin(),v.end(),x)-v.begin()+1;
}//离散化处理

void update(int l,int r,int &x,int y,int pos)
{
	T[++cnt]=T[y],T[cnt].sum++,x=cnt;
	if(l==r) return;
	int mid=(l+r)/2;
	if(mid>=pos) update(l,mid,T[x].l,T[y].l,pos);
	else update(mid+1,r,T[x].r,T[y].r,pos);
} 

int query(int l,int r,int x,int y,int k)
{
	if(l==r) return l;
	int mid=(l+r)/2;
	int sum=T[T[y].l].sum-T[T[x].l].sum;//左区间中数的个数是否大于k,
	if(sum>=k) return query(l,mid,T[x].l,T[y].l,k);
	else return query(mid+1,r,T[x].r,T[y].r,k-sum); 
}

int main()
{
	scanf("%d%d",&n,&m);
	for(int i=1;i<=n;i++) scanf("%d",&a[i]),v.push_back(a[i]);
	sort(v.begin(),v.end());
	v.erase(unique(v.begin(),v.end()),v.end());
	for(int i=1;i<=n;i++) update(1,n,root[i],root[i-1],getid(a[i]));
	for(int i=1;i<=m;i++)
	   {
	   	scanf("%d%d%d",&x,&y,&k);
	   	printf("%d\n",v[query(1,n,root[x-1],root[y],k)-1]); //前缀和的思想(y,x-1)
	   }
}

可以先看一下up主连接:主席树 


root[i]表示1-i所形成的的线段树起始的在T【】中的起始位置

T【x】.l表示左子树的位置

T【x】.r表示右子树的位置

通过l,r,pos的关系,划分是左边还是右边(及它是第几大的。和划分树的思想类似)



posted @ 2018-04-01 14:37  The-Pines-of-Star  阅读(95)  评论(0编辑  收藏  举报