HDU 1000 & HDU1001 & 字符串连接

A + B Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 571020    Accepted Submission(s): 181151


Problem Description
Calculate A + B.
 

 

Input
Each line will contain two integers A and B. Process to end of file.
 

 

Output
For each case, output A + B in one line.
 

 

Sample Input
1 1
 

 

Sample Output
2
#include <iostream>
#include <cstdio>

using namespace std;

int main()
{
    int a=1,b=1;
    while(scanf("%d %d",&a,&b)!=EOF){
        printf("%d\n",a+b);
    }
    return 0;
}
View Code

 

 

Sum Problem

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 410639    Accepted Submission(s): 103262


Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
 

 

Input
The input will consist of a series of integers n, one integer per line.
 

 

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
 

 

Sample Input
1 100
 

 

Sample Output
1 5050
#include <iostream>
#include <cstdio>
using namespace std;

int main()
{
    int t;
    int sum=0;
    while(scanf("%d",&t)!=EOF){
        for(int i=1;i<=t;i++){
            sum+=i;
        }
        printf("%d\n\n",sum);
        sum=0;
    }
    return 0;
}
View Code

 

字符串连接:

#include <iostream>
#include <cstdio>

using namespace std;

int main()
{
    char a[20]="i love";
    char b[20]="you!";
    char c[40];
    sprintf(c,"%s %s",a,b);
    printf("%s",c);
    return 0;
}
View Code

 

posted @ 2016-06-16 10:12  多一份不为什么的坚持  阅读(150)  评论(0编辑  收藏  举报