POJ 1979 Red and Black

题目链接:

http://poj.org/problem?id=1979

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
Hint:
题意:
一个人在一个矩形的房间里面走,这个人只能走黑色的格子,问这个人最多能走多少黑色的格子。
'.'——表示黑色的格子
'#'——表示红色的格子
'@'——表示人的初始的位子
题解:
dfs直接做就行了,简单的递归。
代码:
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define met(a,b) memset(a,b,sizeof(a))
const int maxn = 20+10;
char map[maxn][maxn];
int visited[maxn][maxn];
int n,m;
int ans;
int go(int x,int y)
{
    if(0<=x&&x<m&&0<=y&&y<n&&map[x][y]!='#')
        return true;
    else
        return false;
}
void dfs(int x,int y)
{
    if(!visited[x][y]&&go(x,y))
    {
        visited[x][y]=true;
        ++ans;
        dfs(x+1,y);
        dfs(x-1,y);
        dfs(x,y+1);
        dfs(x,y -1);
    }
}
int main()
{
    while(scanf("%d%d",&n,&m)&&n!=0&&m!=0)
    {
        for(int i=0;i<m;i++)
            scanf("%s",map[i]);
        ans=0;
        int x=0,y=0;
        met(visited,0);
        for(int i=0;i<m;i++)
            for(int j=0;j<n;j++)
            {
                if(map[i][j]=='@')
                {
                    x=i;
                    y=j;
                    break;
                }
            }
        //printf("%d%d\n",x,y);
        
        dfs(x,y);
        printf("%d\n",ans);
    }
}

 



posted @ 2016-08-31 20:40  _Silver  阅读(92)  评论(0编辑  收藏  举报