BFS + 优先队列
问题2:走迷宫升级版——边的权值不同
单点时限: 2.0 sec
内存限制: 256 MB
一天,sunny 不小心进入了一个迷宫,不仅很难寻找出路,而且有的地方还有怪物,但是 sunny 有足够的能力杀死怪物,但是需要一定的时间,但是 sunny 想早一点走出迷宫,所以请你帮助他计算出最少的时间走出迷宫,输出这个最少时间。
我们规定每走一格需要时间单位 1, 杀死怪物也需要时间 1, 如果不能走到出口,则输出 impossible. 每次走只能是上下左右 4 个方向。
输入格式
每次首先 2 个数 n,m (0<n,m≤200),代表迷宫的高和宽,然后 n 行,每行 m 个字符。
S 代码你现在所在的位置。
T 代表迷宫的出口。
# 代表墙,你是不能走的。
X 代表怪物。
. 代表路,可以走。
处理到文件结束。
输出格式
输出最少的时间走出迷宫。不能走出输出 impossible。
样例
输入样例:
4 4
S.X.
#..#
..#.
X..T
4 4
S.X.
#..#
..#.
X.#T
输出样例:
6
impossible
算法(BFS + 优先队列)
题意: 走迷宫,求最短路径,上下左右走一格花费1,走到有怪的格子花费2.
思路: 将每一点的坐标和由起点到该点的距离存入结构体.
由起点开始,将该点存入优先队列,以到起点的距离dis为优先级,每次取出dis最小的,向外扩散。
相当于第一轮得出所有到起点距离为1的点,第二轮得出所有到起点距离为2的点。
注意: 对普通的最短路问题,由于每个各自的花费相同,因此每次存入的点优先级都相同.故不需要使用优先队列,但本题存在有无怪物的区别,每次存入的格子的优先级可能不同,故使用优先队列。
#include<stdio.h>
#include<queue>
#include<iostream>
using namespace std;
char g[201][201];
int sx, sy, tx, ty;
//上下左右4个方向
int dx[4] = { 1,0,-1,0 };
int dy[4] = { 0,1,0,-1 };
int m, n;
struct node {
int x, y, dis;
// bool operator < (const node & other) const {
// return dis > other.dis; // 如果 a.dis 大于 b.dis,则 a 被认为是小于 b
// }
};
// 自定义比较器
struct CompareNode {
bool operator() (const node& a, const node& b) {
return a.dis > b.dis;
}
// (node) a < b 是否成立 ---->要满足返回的值为 true 的条件
};
/*
在默认情况下,priority_queue 使用 operator< 来决定优先级,而 true 表示 a 优先于 b.
*/
void bfs() {
// priority_queue<node> q;
// 或者可以采用小根堆的自定义重载逻辑
priority_queue<node,vector<node>,CompareNode> q;
node st { sx,sy,0 };
g[sx][sy] = '#';
q.push(st);
while (!q.empty()) {
node p = q.top();
q.pop();
//若已找到,则退出
if (p.x == tx && p.y == ty) {
cout << p.dis << endl;
return;
}
for (int i = 0; i < 4; ++i) {
int nx = p.x + dx[i];
int ny = p.y + dy[i];
node np{ nx,ny, 0};
if (nx >= 0 && nx < n&&ny >= 0 && ny < m&&g[nx][ny] != '#') {
if (g[nx][ny] == 'X')
np.dis = p.dis + 2;
else
np.dis = p.dis + 1;
g[np.x][np.y] = '#';
q.push(np);
}
}
}
printf("impossible\n");
}
int main() {
while (cin>>n>>m) {
for (int i = 0; i < n; i++)
scanf("%s", g[i]);
for(int i=0; i<n; i++)
for (int j = 0; j < m; j++) {
if (g[i][j] == 'S')
sx = i, sy = j;
else if (g[i][j] == 'T')
tx = i, ty = j;
}
bfs();
}
return 0;
}