HDU 1711 Number Sequence(KMP)

 

 

          Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6296    Accepted Submission(s): 2845


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

 

Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1
 

 

Sample Output
6
-1
 

 

Source
 

 

Recommend
lcy
 
 

题意:给两个数字序列,判断第一个是否包含了第二个数列。

分析:KMP算法的典型运用。

KMP算法(详细资料参考:http://www.cnblogs.com/dolphin0520/archive/2011/08/24/2151846.html

 

 

#include<iostream>
using namespace std;
#define MAXN 1000000
#define MAXM 10000
int a[MAXN],b[MAXM];
int next[MAXN];
int n,m;
void getNext(int p[],int next[])
{
    int j,k;
    next[0]=-1;
    j=0;
    k=-1;
    while(j<m-1)
    {
        if(k==-1||p[j]==p[k])//匹配的情况下,p[j]==p[k] 
        {
            j++;
            k++;
            next[j]=k;
        }
        else//p[j]!=p[k] 
            k=next[k];
    }
}
int KMPMatch(int s[],int p[])
{    
    int i,j;
    i=0;
    j=0;
    getNext(p,next);
    while(i<n)
    {
        if(j==-1||s[i]==p[j])
        {
            i++;
            j++;
        }
        else
        {
            j=next[j];//消除了指针i的回溯 
        }
        if(j==m)
            return i-m+1;
    }
    return -1;
}
int main()
{
    int t,i,j;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d",&n,&m);
        for(i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(i=0;i<m;i++)
            scanf("%d",&b[i]);
        printf("%d\n",KMPMatch(a,b));
    }
    return 0;
}

 

 

 

posted @ 2012-09-13 21:41  Suhx  阅读(443)  评论(0编辑  收藏  举报