HDU 2709 Sumsets(递推)

 

 

          Sumsets

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 863    Accepted Submission(s): 339


Problem Description
Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).
 

 

Input
A single line with a single integer, N.
 

 

Output
The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).
 

 

Sample Input
7
 

 

Sample Output
6
 

 

Source
 

 

Recommend
teddy
 
 
 
分析(转):

设a[n]为和为 n 的种类数;

根据题目可知,加数为2的N次方,即 n 为奇数时等于它前一个数 n-1 的种类数 a[n-1] ,若 n 为偶数时分加数中有无 1 讨论,即关键是对 n 为偶数时进行讨论:

1.n为奇数,a[n]=a[n-1]

2.n为偶数:

(1)如果加数里含1,则一定至少有两个1,即对n-2的每一个加数式后面 +1+1,总类数为a[n-2];

(2)如果加数里没有1,即对n/2的每一个加数式乘以2,总类数为a[n-2];

所以总的种类数为:a[n]=a[n-2]+a[n/2];

 

#include<iostream>
using namespace std;
int a[1000000];
int main()
{
    int i,n;
    a[1]=1;
    a[2]=2;
    for(i=3;i<=1000000;i++)
    {
        if(i%2==0)
        {
            a[i]=a[i-2]+a[i/2];
            if(a[i]>999999999)
                a[i]%=1000000000;
        }
        else
            a[i]=a[i-1];
    }
    while(~scanf("%d",&n))
    {        
        printf("%d\n",a[n]);
    }
    return 0;
}

 

posted @ 2012-09-11 21:01  Suhx  阅读(453)  评论(0编辑  收藏  举报