HDU 1114 Piggy-Bank(完全背包)

 

 

          Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5684    Accepted Submission(s): 2854


Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!
 

 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.
 

 

Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".
 

 

Sample Input
3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4
 

 

Sample Output
The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.
 

 

Source
 

 

Recommend
Eddy
 
 
题意:给定一个储蓄罐可容纳的重量和n个价值为p重量为w的硬币,问在填满储蓄罐的情况最小的价值为多少?如果没办法填满输出This is impossible. 
这是道完全背包的题目,有变形,要求在限定了重量的Bank中装入尽可能少的钱数。一般的完全背包是求装入尽可能多的钱数。所以只需在初始化的时候做一下变形:将dp[0]=0,其他的都初始化为无穷大即可。在求dp的时候,要将max改为min.状态转移方程:dp[j]=Min(dp[j],dp[j-weight[i]]+value[i]);
 
分析:01背包更新状态时从V(背包的容积)开始更新。 而完全背包则可以直接从当前物品v[i]开始更新。原因是完全背包的特点恰是每种物品可选无限件,所以在考虑“加选一件第i种物品”这种策略时,需要一个可能已选入第i种物品的子结果f[i][v-c[i]],所以就可以并且必须采用v=0..V的顺序循环。
 
 
#include<iostream>
using namespace std;
#define INF 100000000
int dp[50005];
int Min(int x,int y)
{
    return  x<y?x:y;
}
int main()
{
    int t,e,f,n,p[505],w[505];
    int i,j,k;
    memset(dp,0,sizeof(dp));
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d %d",&e,&f,&n);
        int v=f-e;
       for(i=1;i<=v;i++)//dp[0]=0
            dp[i]=INF;//初始化为无穷大
        for(i=1;i<=n;i++)
            scanf("%d %d",&p[i],&w[i]);
        for(i=1;i<=n;i++)
        {
            for(j=w[i];j<=v;j++)
            {
                dp[j]=Min(dp[j],dp[j-w[i]]+p[i]);
            }
        }
        if(dp[v]==INF)
            printf("This is impossible.\n");
        else
        printf("The minimum amount of money in the piggy-bank is %d.\n",dp[v]);
    }
    return 0;
}

 

posted @ 2012-09-02 13:44  Suhx  阅读(260)  评论(0编辑  收藏  举报