HDU 1251 统计难题(字典树)

非常经典的字典树问题

          统计难题

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131070/65535 K (Java/Others)
Total Submission(s): 10514    Accepted Submission(s): 4328


Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
 

 

Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.
 

 

Output
对于每个提问,给出以该字符串为前缀的单词的数量.
 

 

Sample Input
banana
band
bee
absolute
acm
 
ba
b
band
abc
 

 

Sample Output
2
3
1
0
 

 

Author
Ignatius.L
 

 

Recommend
Ignatius.L
 
 
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
struct node
{
    node *str[26];
    int num;
};
node *head;
void insert(char ch[])
{
    node *t,*s=head;
    int i,j;
    int len=strlen(ch);
    for(j=0;j<len;j++)
    {
        int id=ch[j]-'a';
        if(s->str[id]==NULL)
        {
            t=new node;
            for(i=0;i<=25;i++)
                t->str[i]=NULL;
            t->num=0;
            s->str[id]=t;
        }
        s=s->str[id];
        s->num++;
    }
}
int  Find(char ch[])
{
    node *s=head;
    int i,count;
    int len=strlen(ch);
    for(i=0;i<len;i++)
    {
        int id=ch[i]-'a';
        if(s->str[id]==NULL)
        {
            count=0;
            return count;
        }
        else
        {
            s=s->str[id];
            count=s->num;
        }
    }
    return count;
}
int main()
{
    int i;
    char tmp[15];
    head=new node;
    for(i=0;i<=25;i++)
    {
        head->str[i]=NULL;
        head->num=0;
    }
    while(gets(tmp),strcmp(tmp,""))
    {
        insert(tmp);
    }
    while(gets(tmp))
    {
        cout<<Find(tmp)<<endl;
    }
    delete []head;
    return 0;
}

 

posted @ 2012-08-14 22:10  Suhx  阅读(277)  评论(0编辑  收藏  举报