HDU 3549 Flow Problem(最大流最短路径增广)

 

          Flow Problem

Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 3301    Accepted Submission(s): 1552


Problem Description
Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.
 

 

Input
The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)
 

 

Output
For each test cases, you should output the maximum flow from source 1 to sink N.
 

 

Sample Input
2
3 2
1 2 1
2 3 1
3 3
1 2 1
2 3 1
1 3 1
 

 

Sample Output
Case 1: 1
Case 2: 2
 

 

Author
HyperHexagon
 

 

Source
 

 

Recommend
zhengfeng
 
 
用最大流最短路径增广算法(EK算法)解决
 
#include<iostream>
#include<queue>
using namespace std;
#define INF 0xfffffff
#define maxn 50
#define min(x,y)(x<y?x:y)
int cap[maxn][maxn];
int n,m,s,t,maxflow;
int flow[maxn][maxn],parent[maxn],d[maxn];
void Edmonds_Karp(int s,int t,int nnum)
{
 maxflow=0;
 memset(flow,0,sizeof(flow));
 memset(parent,0,sizeof(parent));
 while(true)
 {
  memset(d,0,sizeof(d));
  queue<int>que;
  d[s]=INF;
  que.push(s);
  while(!que.empty())
  {
   int u=que.front();
   que.pop();
   for(int v=0;v<nnum;v++)
   {
    if(!d[v]&&cap[u][v]>flow[u][v])
    {
     parent[v]=u;
     que.push(v);
     d[v]=min(d[u],cap[u][v]-flow[u][v]);
    }
   }
  }
  if(!d[t])
   break;
  for(int u=t;u!=s;u=parent[u])
  {
   flow[parent[u]][u]+=d[t];
   flow[u][parent[u]]-=d[t];
  }
  maxflow+=d[t];
 }
}
int main()
{
 int t,cases=0,i;
 scanf("%d",&t);
 while(t--)
 {
  memset(cap,0,sizeof(cap));
  scanf("%d %d",&n,&m);
  while(m--)
  {
   int x,y,c;
   scanf("%d %d %d",&x,&y,&c);
   cap[x-1][y-1]+=c;    
  }
  Edmonds_Karp(0,n-1,n);
  printf("Case %d: %d\n",++cases,maxflow);
 }
 return 0;
} 

 

posted @ 2012-08-14 21:09  Suhx  阅读(261)  评论(0编辑  收藏  举报