Headshot

题目

You have a revolver gun with a cylinder that has n chambers. Chambers are located in a circle on a
cylinder. Each chamber can be empty or can contain a round. One chamber is aligned with the gun’sbarrel. When trigger of the gun is pulled, the gun’s cylinder rotates, aligning the next chamber with the barrel, hammer strikes the round, making a shot by firing a bullet through the barrel. If the chamber is empty when the hammer strikes it, then there is no shot but just a “click”.
这里写图片描述
You have found a use for this gun. You are playing Russian Roulette with your friend. Your friend
loads rounds into some chambers, randomly rotates the cylinder, aligning a random chamber with a
gun’s barrel, puts the gun to his head and pulls the trigger. You hear “click” and nothing else — the
chamber was empty and the gun did not shoot.
Now it is your turn to put the gun to your head and pull the trigger. You have a choice. You
can either pull the trigger right away or you can randomly rotate the gun’s cylinder and then pull the
trigger. What should you choose to maximize the chances of your survival?

Input

The input file contains several datasets. A dataset consists of a single line with a string of n digits ‘0’
and ‘1’ (2 ≤ n ≤ 100). This line of digits represents the pattern of rounds that were loaded into the
gun’s chambers. ‘0’ represent an empty chamber, ‘1’ represent a loaded one. In this representation,
when cylinder rotates before a shot, the next chamber to the right gets aligned with the barrel for a
shot. Since the chambers are actually located on a circle, the first chamber in this string follows the
last one. There is at least one ‘0’ in this string.

Output

For each dataset, write to the output file one of the following words (without quotes):
• ‘SHOOT’ — if pulling the trigger right away makes you less likely to be actually shot in the head
with the bullet (more likely that the chamber will be empty).
• ‘ROTATE’ — if randomly rotating the cylinder before pulling the trigger makes you less likely to
be actually shot in the head with the bullet (more likely that the chamber will be empty).
• ‘EQUAL’ — if both of the above choices are equal in terms of probability of being shot.

Sample Input

0011
0111
000111

Sample Output

EQUAL
ROTATE
SHOOT

题意

你跟人决斗,用手枪向自己的脑袋开枪。另外一个人先开,是空枪。接着轮到了你,现在给你子弹序列。你需要编写程序决定是先转一下还是直接开枪生还的可能大(可以旋转到任意位置,且开枪之后会自动转到下一格)

思路

设连续两个空弹的个数为E1,空弹的个数为E2,子弹的个数为len
首先我们想,如果直接开枪的话,有两个连续空弹的可能是多少呢?
另一个人拿到的空弹是是E2颗弹中的一个,也就是E2/1
那么连续两个都是空弹的概率就是

E1/E2

转一下的概率比较好想,就是

E2/len

代码

#include<cstdio>
#include<cstring>
using namespace std;
#define MAXN 100
int main(){
    char G[2*MAXN+5];
    while(~scanf("%s",G)){
        int len=strlen(G);
        G[len]=G[0];
        double E1=0.0,E2=0.0;
        for(int i=0;i<len;i++){
            if(G[i]=='0'){
                E1+=1.0;
                if(G[i]==G[i+1])
                    E2+=1.0;        
            } 
        }
        double A1=E2/E1,A2=E1/len;
        if(A1>A2) printf("SHOOT\n");
        else if(A1==A2) printf("EQUAL\n");
        else printf("ROTATE\n");
    }
}
posted @ 2018-06-04 13:58  SteinGate  阅读(199)  评论(0编辑  收藏  举报