D - Frogger

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题解:首先这道题不是让我们求最短路径,而是让我们去让我们找路径中最大值的最小值,并且n的范围是小于二百的,故可以用

floyed算法

接下来是代码:

提交的时候最好用G++,c++我的pow()函数好像

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
double a[201][201];
int b[201][3];
int main()
{
    int n,cnt=1;
    while(~scanf("%d",&n)&&n)
    {
     for (int i=1;i<=n;i++)
        scanf("%d %d",&b[i][1],&b[i][2]);
    for (int i=1;i<=n-1;i++)
    {
        for (int j=i+1;j<=n;j++)
            a[i][j]=a[j][i]=sqrt(pow((b[i][1]-b[j][1]),2)+pow((b[i][2]-b[j][2]),2));
    }
    for (int k=1;k<=n;k++)
        for (int i=1;i<=n;i++)
            for (int j=2;j<=n;j++)
            {
                if (a[i][j]>a[i][k]&&a[i][j]>a[k][j])
                {
                    if (a[i][k]>a[k][j])
                        a[i][j]=a[j][i]=a[i][k];
                    else
                        a[i][j]=a[j][i]=a[k][j];
                }
            }
    printf("Scenario #%d\n",cnt++);
    printf("Frog Distance = %.3f\n",a[1][2]);
    printf("\n");
   }
}

 

posted @ 2018-11-18 10:18  black_hole6  阅读(96)  评论(0编辑  收藏  举报