A Simple Problem with Integers(线段树区间更新复习,lazy数组的应用)-------------------蓝桥备战系列

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<vector>
#include<cmath>

const int maxn=1e5+5;
typedef long long ll;
using namespace std;

struct node
{
	ll l,r,sum;
}tree[maxn<<2];
ll lazy[maxn<<2];
void pushup(int m)
{

	tree[m].sum=tree[m<<1].sum+tree[m<<1|1].sum;
}
void pushdown(int m,int l)
{
	if(lazy[m]!=0)
	{
		lazy[m<<1]+=lazy[m];
		lazy[m<<1|1]+=lazy[m];
		tree[m<<1].sum+=lazy[m]*(l-(l>>1));
		tree[m<<1|1].sum+=lazy[m]*(l>>1);
		lazy[m]=0;
	}
}
void build(int m,int l,int r)
{
	tree[m].l=l;
	tree[m].r=r;
	if(l==r)
	{
		scanf("%lld",&tree[m].sum);
		return;
	}
	int mid=(l+r)>>1;
	build(m<<1,l,mid);
	build(m<<1|1,mid+1,r);
	pushup(m);
}
void update(int m,int l,int r,int val)
{
	if(tree[m].l==l&&tree[m].r==r)
	{
		lazy[m]+=val;
		tree[m].sum+=(ll)val*(r-l+1);
		return;
	}
	if(tree[m].l==tree[m].r)
	return;
	int mid=(tree[m].l+tree[m].r)>>1;
	pushdown(m,tree[m].r-tree[m].l+1);
	if(r<=mid)
	{
		update(m<<1,l,r,val);
	}
	else if(l>mid)
	{
		update(m<<1|1,l,r,val);
	}
	else 
	{
		update(m<<1,l,mid,val);
		update(m<<1|1,mid+1,r,val);
	}
	pushup(m);
}
ll query(int m,int l,int r)
{
	if(tree[m].l==l&&tree[m].r==r)
	{
		return tree[m].sum;
	}
	pushdown(m,tree[m].r-tree[m].l+1);
	int mid=(tree[m].l+tree[m].r)>>1;
	ll res=0;
	if(r<=mid)
	{
		res+=query(m<<1,l,r);
	}
	else if(l>mid)
	{
		res+=query(m<<1|1,l,r);
	}
	else 
	{
		res+=(query(m<<1,l,mid)+query(m<<1|1,mid+1,r));
		
	}
	return res;
	
}
int main()
{
    std::ios::sync_with_stdio(false);
    std::cin.tie(0);
    int n,m;
    cin>>n>>m;
    build(1,1,n);

    char op[2];
    int l,r,val;
    for(int t=0;t<m;t++)
    {
    	scanf("%s",op);
    	if(op[0]=='Q')
    	{
    		scanf("%d%d",&l,&r);
    		printf("%lld\n",query(1,l,r));
		}
		else 
		{
			scanf("%d%d%d",&l,&r,&val);
			update(1,l,r,val);
		}
	}

	return 0;
}

 

posted @ 2019-04-09 16:04  black_hole6  阅读(178)  评论(0编辑  收藏  举报