1023

题目大意:

In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1--300, counted clockwise, we assume the number of rows were infinite.<br>These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1--N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).<br>Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R.<br>

 Input
There are many test cases:<br>For every case: <br>The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.<br>Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.<br><br>
 Output
For every case: <br>Output R, represents the number of incorrect request.<br>
 Sample Input
10 10 1 2 150 3 4 200 1 5 270 2 6 200 6 5 80 4 7 150 8 9 100 4 8 50 1 7 100 9 2 100
 Sample Output
2 <div style='font-family:Times New Roman;font-size:14px;background-color:F4FBFF;border:#B7CBFF 1px dashed;padding:6px'><div style='font-family:Arial;font-weight:bold;color:#7CA9ED;border-bottom:#B7CBFF 1px dashed'><i>Hint</i></div> Hint: (PS: the 5th and 10th requests are incorrect) </div>
有n个人坐在体育馆里面,然后给出m个他们之间的距离, A B X, 代表B的座位比A多X. 然后求出这m个关系之间有多少个错误,所谓错误就是当前这个关系与之前的有冲突
解题思路:
用带权并查集做, 对于并查集中的每一棵数, 树根的距离为0,然后以树根作为参照,每个结点的权值代表与树根的距离
代码:
#include<cstdio>  

    #include<cmath>  
    using namespace std;  
    #define N 50005  
    int f[N], rank[N], n, m;  
      
    void init(){  
        for(int i=0; i<=n; ++i)  
            f[i]=i, rank[i]=0;  
    }  
    int find(int x){  
        if(x==f[x]) return f[x];  
        int t=f[x];  
        f[x] = find(f[x]);  
        rank[x] += rank[t];  
        return f[x];  
    }  
    bool Union(int x,int y, int m){  
        int a=find(x), b=find(y);  
        if(a==b){  
            if(rank[x]+m!=rank[y])  
                return false;  
            return true;  
        }  
        f[b] = a;  
        rank[b] = rank[x]+m-rank[y];  
        return true;  
    }  
      
    int main(){  
        int a,b,x;  
        while(~scanf("%d%d",&n,&m)){  
            init();  
            int cnt=0;  
            for(int i=0; i<m; ++i){  
                scanf("%d%d%d",&a,&b,&x);  
                if(!Union(a, b, x)){  
                    ++cnt;  
                }  
            }  
            printf("%d\n",cnt);  
        }  
        return 0;  
    }  

 

 
posted @ 2016-06-20 21:55  Si考者  阅读(119)  评论(0编辑  收藏  举报