HDU1250 Hat's Fibonacci

Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 

Input
Each line will contain an integers. Process to end of file.
 

Output
For each case, output the result in a line.
 

Sample Input
100
 

Sample Output
4203968145672990846840663646


Note:
No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
题目
#include<stdio.h>
#include<string.h>
#define k 10000
#define m 260
#define mod 100000000
int a[k][m];
void bigNumber(){
    a[1][1]=a[2][1]=a[3][1]=a[4][1]=1;
    for(int i=5;i<k;i++){
        int t=0;
        for(int j=1;j<m;j++){
            t=t+a[i-1][j]+a[i-2][j]+a[i-3][j]+a[i-4][j];
            a[i][j]=t%mod;
            t=t/mod;
        }
    }
}
int main(){
    int n;
    memset(a,0,sizeof(a));
    bigNumber();
    while(scanf("%d",&n)!=EOF){
        int j=m-1;
        while(a[n][j]==0)
            j--;
        printf("%d",a[n][j--]);
        while(j>=1){
            printf("%08d",a[n][j]);
            j--;
        }
        printf("\n");
    }
    return 0;
}
AC代码

目前在一般的电脑中,int占用4字节,32比特,数据范围为-2147483648~2147483647[-2^31~2^31-1]

思路:

    用二维数组存储,数组中的一个用来存储8位数字,最多2005/8=250.625,所以260位来存储数据绰绰有余,然后两个for遍历执行就可以啦

posted @ 2018-07-08 16:13  子诚-  阅读(148)  评论(0编辑  收藏  举报