UVa - 11059 - Maximum Product

Given a sequence of integers S = {S1, S2, . . . , Sn}, you should determine what is the value of the maximum positive product involving consecutive terms of S. If you cannot find a positive sequence, you should consider 0 as the value of the maximum product.

Input

Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Si is an integer such that −10 ≤ Si ≤ 10. Next line will have N integers, representing the value of each element in the sequence. There is a blank line after each test case. The input is terminated by end of file (EOF).

Output

For each test case you must print the message: ‘Case #M: The maximum product is P.’, where M is the number of the test case, starting from 1, and P is the value of the maximum product. After each test case you must print a blank line.

Sample Input

3

2 4 -3

5

2 5 -1 2 -1

Sample Output

Case #1: The maximum product is 8. Case #2: The maximum product is 20.

#include<iostream>
#include<algorithm>
using namespace std;
int main(){
    long long m,n,a[20];
    long long i,j,k,l,max,s=0;
    while(cin>>n&&n){
        max=0;l=1;
        s++;
        for(i=0;i<n;i++){
            cin>>a[i];
        }
        for(i=0;i<n;i++){
            for(j=0;j<n;j++){
                l=1;
                for(k=i;k<=j;k++){
                    l=l*a[k];
                    if(l>max)
                        max=l;
                }
            }
        }
        cout<<"Case #"<<s<<": The maximum product is "<<max<<"."<<endl;
        cout<<endl;
    }
    return 0;
}
View Code

【分析】

    连续子序列求最大乘积,我们要做的就是抓住起点和终点进行枚举,元素的最大值为10且不超过18个元素,所以乘积肯定在10的18次方以内,用long long存储然后比较求出最大值即可。

posted @ 2018-03-28 22:55  子诚-  阅读(117)  评论(0编辑  收藏  举报