F - Oil Deposits 【地图型BFS+联通性】

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 

InputThe input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 
OutputFor each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets. 
Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 

Sample Output

0
1
2
2
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<string>
#include<vector>
#include<stack>
#include<bitset>
#include<cstdlib>
#include<cmath>
#include<set>
#include<list>
#include<deque>
#include<map>
#include<queue>
#define ll long long
#define inf 0x3fffffff
using namespace std;
const int maxn = 105;
int num;   
int n,m;//注意!定义全局变量不能在函数里面重定义了!! 
char a[maxn][maxn];
int judge(int x,int y)
{
    if(x<0||y<0||x>=n||y>=m||a[x][y]=='*')
    return 0;
    return 1;
}
 struct Node
{
    int x,y;
};

int d[8][2]={{0,-1},{0,1},{-1,0},{1,0},{-1,-1},{1,-1},{-1,1},{1,1}};

queue<Node> q;

void bfs(int i,int j)
{
    
    Node fir,tmp;
    fir.x=i;
    fir.y=j;
    q.push(fir);

    while(!q.empty())
    {
        fir=q.front();
        q.pop();

        for(int i=0;i<8;i++)//遍历8个方向
        {
           
             tmp.x=fir.x+d[i][0];
             tmp.y=fir.y+d[i][1];
       
             if(judge(tmp.x,tmp.y))
             {
                 q.push(tmp);
                a[tmp.x][tmp.y]='*';
             }
        }
    }
    return ;
}

int main()
{

    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0) break;
        num=0;
        for(int i=0;i<n;i++)
            scanf("%s",&a[i]);
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                if(a[i][j]=='@')
                {
                    bfs(i,j);
                    num++;
                }
            }
        }
        printf("%d\n",num);
    }
    return 0;
}
View Code

 

posted @ 2017-08-21 19:41  Roni_i  阅读(200)  评论(0编辑  收藏  举报