HDU 2700 Parity(字符串,奇偶性)

         Parity

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1855    Accepted Submission(s): 1447

Problem Description
A bit string has odd parity if the number of 1's is odd. A bit string has even parity if the number of 1's is even.Zero is considered to be an even number, so a bit string with no 1's has even parity. Note that the number of 0's does not affect the parity of a bit string.
 
Input
The input consists of one or more strings, each on a line by itself, followed by a line containing only "#" that signals the end of the input. Each string contains 1–31 bits followed by either a lowercase letter 'e' or a lowercase letter 'o'.
 
Output
Each line of output must look just like the corresponding line of input, except that the letter at the end is replaced by the correct bit so that the entire bit string has even parity (if the letter was 'e') or odd parity (if the letter was 'o').
 
Sample Input
101e
010010o
1e
000e
110100101o
#
 
Sample Output
1010
0100101
11
0000
1101001010
 
Source
 
 
 
/*
e:是要使字符串中1的个数变成偶数
o:是要使字符串中1的个数变成奇数
*/
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<cmath>
using namespace std;
int main()
{
    char s[100];
    int cnt;
    while(~scanf("%s",s))
    {
        cnt=0;
        if(s[0]=='#')
            break;
        int len=strlen(s);
        for(int i=0;i<len;i++)
        {
            if(s[i]=='1')
                cnt++;
        }
        if(cnt%2==0)
            {
                if(s[len-1]=='e')//最后一位是len-1 !
                    s[len-1]='0';
                if(s[len-1]=='o')
                    s[len-1]='1';
            }
            else
            {
                if(s[len-1]=='o')
                    s[len-1]='0';
                if(s[len-1]=='e')
                    s[len-1]='1';
            }
        for(int i=0;i<len;i++)
        {
            printf("%c",s[i]);
        }
        printf("\n");
    }
}

  

posted @ 2017-07-19 15:53  Roni_i  阅读(288)  评论(0编辑  收藏  举报