Fibonacci Again (简单规律题)

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2). 

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000). 

Output

Print the word "yes" if 3 divide evenly into F(n). 

Print the word "no" if not. 

Sample Input

0
1
2
3
4
5

Sample Output

no
no
yes
no
no
no

 

 

#include<iostream>
using namespace std;

int main()
{
	int n,m,j,k,i,T;
	while (cin>>i)
	{
		if (i==0) cout<<"no"<<endl;
		else if (i==1) cout<<"no"<<endl;
		else
		{
			if (i%4==2) cout<<"yes"<<endl;
			else
			cout<<"no"<<endl;
		}
	}
	
	return 0;
}

 

posted @ 2019-01-12 16:04  RomanticChopin  阅读(226)  评论(0编辑  收藏  举报
-->
Live2D