蓝桥杯 算法提高 队列操作 (STL基本操作)

问题描述

  队列操作题。根据输入的操作命令,操作队列(1)入队、(2)出队并输出、(3)计算队中元素个数并输出。

输入格式

  第一行一个数字N。
  下面N行,每行第一个数字为操作命令(1)入队、(2)出队并输出、(3)计算队中元素个数并输出。

输出格式

  若干行每行显示一个2或3命令的输出结果。注意:2.出队命令可能会出现空队出队(下溢),请输出“no”,并退出。

样例输入

7
1 19
1 56
2
3
2
3
2

样例输出

19
1
56
0
no

数据规模和约定

  1<=N<=50

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<stack>
using namespace std;

int main()
{
	queue<int>q;
	int n,m,j,k,i,T,x,op;
	cin>>T;
	while (T--)
	{
		cin>>op;
		if (op==1)
		{
			cin>>x;
			q.push(x);
		}
		else if (op==2)
		{
			if (q.empty())
			{
				cout<<"no"<<endl;
				return 0;
			}
			
			else
			{
				x = q.front();
				q.pop();
				cout<<x<<endl;
			}
		}
		else
			cout<<q.size()<<endl;
	}
	
	return 0;
}

 

posted @ 2019-02-03 16:51  RomanticChopin  阅读(195)  评论(0编辑  收藏  举报
-->
Live2D