POJ 2478 Farey Sequence(欧拉函数前n项和)
Description
The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}
You task is to calculate the number of terms in the Farey sequence Fn.
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}
You task is to calculate the number of terms in the Farey sequence Fn.
Input
There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 10 6). There are no blank lines between cases. A line with a single 0 terminates the input.
Output
For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn.
Sample Input
2 3 4 5 0
Sample Output
1 3 5 9
题意:求欧拉函数的前n项和。
题解:打表筛选即可。
#include <iostream> using namespace std; typedef long long ll; const int maxn=1e6+5; ll a[maxn]; void get() { for(int i=2;i<maxn;i++) { if(!a[i]) { for(int j=i;j<maxn;j+=i) //已经包含了素筛的思想 { if(!a[j]) a[j]=j; a[j]=a[j]/i*(i-1); } } a[i]+=a[i-1]; } } int main() { get(); int n; while(cin>>n&&n) cout<<a[n]<<endl; return 0; }