POJ 1742 Coins(多重背包的可行性问题)
Description
People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
Input
The input contains several test cases. The first line of each test case contains two integers n(1<=n<=100),m(m<=100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1<=Ai<=100000,1<=Ci<=1000). The last test case is followed by two zeros.
Output
For each test case output the answer on a single line.
Sample Input
3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0
Sample Output
8
4
/**
poj 1742 多重背包的可行性问题
题目大意:给定n种面值的硬币面值分别为wi个数为ci,问用这些硬币可以组成1~m之间的多少面值
解题思路:楼教主的男人八题之一,算是一个经典的问题,定义一个sum数组。每次填dp[j]时直接由dp[j-weight[i]]推出,
前提是sum[j-w[i]]<c[i].sum每填一行都要清零,sum[j]表示当前物品填充j大小的包需要至少使用多少个.复杂度O(n*m)
*/
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <iostream>
using namespace std;
int n,m;
int w[105],c[105],sum[100005],dp[100005];
int main(){
while(~scanf("%d%d",&n,&m)) {
if(n==0&&m==0)break;
for(int i=0;i<n;i++)
scanf("%d",&w[i]);
for(int i=0;i<n;i++)
scanf("%d",&c[i]);
memset(dp,0,sizeof(dp));
dp[0]=1;
int ans=0;
for(int i=0;i<n;i++) {
memset(sum,0,sizeof(sum));
for(int j=w[i];j<=m;j++)
if(!dp[j]&&dp[j-w[i]]&&sum[j-w[i]]<c[i]) {
dp[j]=1;
sum[j]=sum[j-w[i]]+1;
ans++;
}
}
printf("%d\n",ans);
}
return 0;
}
#include <bits/stdc++.h>
using namespace std;
const int N = 10 + 100;
const int M = 10 + 1e5;
int n, m, A[N], C[N];
int main() {
ios::sync_with_stdio(false); cin.tie(0); cout.tie(0);
while (cin >> n >> m && n && m) {
for (int i = 1; i <= n; i++) cin >> A[i];
for (int i = 1; i <= n; i++) cin >> C[i];
bitset<M> dp;
dp[0] = 1;
for (int i = 1; i <= n; i++) {
int k = 1, t = C[i];
while (k < t) {
dp |= (dp << A[i] * k); // 利用 bitset 的特性取得所有组合和
t -= k;
k *= 2;
}
if (t) dp |= (dp << A[i] * t);
}
int ans = 0;
for (int i = 1; i <= m; i++) ans += dp[i];
cout << ans << endl;
}
return 0;
}
/**
状态定义: 设 f(i,j) 表示是否可使用前 i 种硬币拼成 j
转移方程: f(i,j) = f(i-1,j-k*Ai), 0<=k<=Ci
边界条件: f(0,0) = 1, f(0,j) = 0, f(i,0) = 1
**/
#include<bits/stdc++.h>
using namespace std;
const int M = 1e5 + 100;
const int N = 110;
int a[N], c[N], book[M], n, m;
bool dp[M];
//贪心
void Coin() {
memset(dp, false, sizeof dp);
for (int i = 1; i <= n; ++i)cin >> a[i];
for (int i = 1; i <= n; ++i)cin >> c[i];
dp[0] = 1;
for (int i = 1; i <= n; ++i) {
memset(book, 0, sizeof book);
for (int j = a[i]; j <= m; ++j)//贪心
if (!dp[j] && dp[j - a[i]] && book[j - a[i]] < c[i])
dp[j] = true, book[j] = book[j - a[i]] + 1;
}
int ans = 0;
for (int i = 1; i <= m; ++i)if (dp[i])++ans;
cout << ans << endl;
}
int main() {
freopen("in.txt", "r", stdin);
ios::sync_with_stdio(false), cin.tie(0);
while (cin >> n >> m && n) Coin();
}
· 探究高空视频全景AR技术的实现原理
· 理解Rust引用及其生命周期标识(上)
· 浏览器原生「磁吸」效果!Anchor Positioning 锚点定位神器解析
· 没有源码,如何修改代码逻辑?
· 一个奇形怪状的面试题:Bean中的CHM要不要加volatile?
· Obsidian + DeepSeek:免费 AI 助力你的知识管理,让你的笔记飞起来!
· 分享4款.NET开源、免费、实用的商城系统
· 解决跨域问题的这6种方案,真香!
· 一套基于 Material Design 规范实现的 Blazor 和 Razor 通用组件库
· 5. Nginx 负载均衡配置案例(附有详细截图说明++)