#2054:A == B ?(水题坑人)

Problem Description

Give you two numbers A and B, if A is equal to B, you should print "YES", or print "NO".

Input

each test case contains two numbers A and B.

Output

for each case, if A is equal to B, you should print "YES", or print "NO".

Sample Input

1 2
2 2
3 3
4 3

Sample Output

NO
YES
YES
NO

思路:

此题关键是找小数点,找到小数点把最后面无效的零去掉再比较就OK

教训:

一开始做的时候感觉好简单啊,直接string输入然后==比较,然后WA打脸了,发觉可能是大数比较问题,然后long double测试还是没过,想了很久才想到可能是精度问题如000123 和 123 还有小数点 ' . '的问题一些的,不断完善最后才AC了

AC代码

#include<bits/stdc++.h>
using namespace std;
void trim0(string& b)
{
	int len = b.length();
	if(b.find('.')!=string::npos)
	{
		for(int i=len-1;b[i]=='0';i--)
			len--;
		b=b.substr(0,len);
	}
	if(b[len-1]=='.')
		b=b.substr(0,len-1);
}
void main()
{
	string a,b;
	while(cin>>a>>b)
	{
		trim0(a);
		trim0(b);
		if(a==b)
			cout<<"YES"<<endl;
		else
			cout<<"NO"<<endl;
	}
}
posted @   RioTian  阅读(349)  评论(0编辑  收藏  举报
编辑推荐:
· 探究高空视频全景AR技术的实现原理
· 理解Rust引用及其生命周期标识(上)
· 浏览器原生「磁吸」效果!Anchor Positioning 锚点定位神器解析
· 没有源码,如何修改代码逻辑?
· 一个奇形怪状的面试题:Bean中的CHM要不要加volatile?
阅读排行:
· 分享4款.NET开源、免费、实用的商城系统
· Obsidian + DeepSeek:免费 AI 助力你的知识管理,让你的笔记飞起来!
· MongoDB 8.0这个新功能碉堡了,比商业数据库还牛
· 白话解读 Dapr 1.15:你的「微服务管家」又秀新绝活了
· 全程不用写代码,我用AI程序员写了一个飞机大战
点击右上角即可分享
微信分享提示