【最大子列和-在线处理算法】

 

  题目

Given a sequence of K integers { N1​​, N2​​, ..., NK​​ }. A continuous subsequence is defined to be { Ni​​, Ni+1​​, ..., Nj​​ } where 1. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21
 

Sample Output:10 1 4



(有点忙最近,先贴上来之后再写注释)

//更新了注释
  算法:
 #include<iostream>
using namespace std;
int main()
{
    int thissum,sum,n,j;
    int right=0,left=0,blag=0,temp=0,flag=0,set1,set2;
    cin>>n;
    thissum=sum=0;
    for(int i=0;i<n;i++)
    {
        cin>>j;
        //初始化最大子列和的左右端为数列左右端
        if(i==0) set1=j;
        if(i==(n-1)) set2=j;

        if(j>=0) flag=1;
        //blag==0时,将最大子列和的左端存入临时变量temp
               if(blag==0 && j>0)
        {
            temp=j;
            blag=1;
        }
        //累加
        thissum+=j;
        //更新最大和sum和左右端left,right
        //注意此时left更新与right不同,可能没有变化,即blag仍为1。
        if(thissum>sum)
        {
                sum=thissum;
                right=j;
                left=temp;
        }
        //当前子列和为负,不能让后续子列变大,则舍弃,重置blag->重置left
        else if(thissum<0)
        {
            thissum=0;
            blag=0;
        }
           }
           //子列全为负
    if(flag==0)
    {
        cout<<sum<<' '<<set1<<' '<<set2;
    }
    else
    {
        cout<<sum<<' '<<left<<' '<<right;
    }
    return 0;
}

 

 



posted @ 2021-06-22 17:30  Etherealhff  阅读(68)  评论(0编辑  收藏  举报