Sicily 1027 MJ,Nowhere to Hide

1027. MJ, Nowhere to Hide

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

 

On BBS, there is a familiar term called MJ (short for MaJia), which means another BBS ID of one person besides his/her main ID.
These days, a lot of ACMers pour water on the ACMICPC Board of argo. Mr. Guo is very angry about that and he wants to punish these guys. ACMers are all smart boys/girls, right? They usually use their MJs while pouring water, so Mr. Guo can not tell all the IDs apart.  Unfortunately, the IP can not be changed, i.e, the posts of main ID and MJ of the same person has the same IP address, meanwhile, the IP addresses of different person is different.  Assuming that each person has exactly one main ID and one MJ, by reading their posts on BBS, you then tell Mr. Guo whom each MJ belongs to. 

 

Input

 

The first line of each test cases is an even integer n (0<=n<=20), the number of posts on BBS.
Then n lines follow, each line consists of two strings:
BBS_ID IP_Address
BBS_ID means the ID who posts this post. BBS_ID is a string contains only lower case alphabetical characters and its length is not greater than 12. Each BBS ID appears only once in each test cases.
IP_Address is the IP address of that person. The IP address is formatted as “A.B.C.D”, where A, B, C, D are integers ranging from 0 to 255.
It is sure that there are exactly 2 different BBS IDs with the same IP address. The first ID appears in the input is the main ID while the other is the MJ of that person.
Your program should be terminated by n = 0.

 

Output

 

For each test case, output n/2 lines of the following format: “MJ_ID is the MaJia of main_ID”
They should be displayed in the lexicographical order of the main_ID.
Print a blank line after each test cases.
See the sample output for more details.

 

Sample Input

8
inkfish 192.168.29.24
zhi 192.168.29.235
magicpig 192.168.50.170
pegasus 192.168.29.235
iamcs 202.116.77.131
finalBob 192.168.29.24
tomek 202.116.77.131
magicduck 192.168.50.170
4
mmmmmm 172.16.72.126
kkkkkk 192.168.49.161
llllll 192.168.49.161
nnnnnn 172.16.72.126
0

Sample Output

tomek is the MaJia of iamcs
finalBob is the MaJia of inkfish
magicduck is the MaJia of magicpig
pegasus is the MaJia of zhi
 
llllll is the MaJia of kkkkkk
nnnnnn is the MaJia of mmmmmm

Problem Source

ZSUACM Team Member

 

这道题的思路同样比较简单,每一次给出n组字符串,每组包括BBS账号和IP地址,每一个IP地址对应两个不同的BBS账号,先给出的BBS账号(main_ID)是后给出的BBS账号(MJ_ID)的MaJia,然后按照main_ID的字典顺序输出所有对应序列即可。

首先建立一个<string, string>类型的map关联m储存BBS-IP对应关系,建立结构体数组s储存所有BBS之间的对应关系;

然后遍历全部BBS-IP对应关系,当一个IP第一次出现时其m关联字符串为空,此时赋予其对应的BBS的值;当一个IP第二次出现即其关联字符串不为空时,此时IP已经关联的BBS即为main_ID,刚刚遍历到的BBS值即为mj_ID,将其写入结构体数组中,数组跳到下一储存单位即可,通过计数器p来计算最终得到的结构体数组s的数目;

最后自定义cmp对结构体数组s进行排序,关键字为main_ID,将其sort排序后,按照题目要求输出即可,需要注意的是每一个测试样例最后都要有一个空行,不要漏掉。

代码如下:

#include <iostream>
#include <map>
#include <algorithm>
using namespace std;

struct node
{
	string main_id;
	string mj_id;
}s[106];

bool cmp(const node &a,const node &b)
{
	return a.main_id<b.main_id;
}
int main()
{
	int n;
	string BBS,IP;
	while(cin>>n)
	{
		if(n==0) break;
		map<string,string> m;

		int p=0;
		for(int i=0;i<n;i++)
		{
			cin>>BBS>>IP;
			if(m[IP]=="") m[IP]=BBS;
			else 
			{
				s[p].main_id=m[IP];
				s[p].mj_id=BBS;
				p=p+1;
			}
		}

		sort(s,s+p,cmp);
		for(int i=0;i<p;i++)
		{
			cout<<s[i].mj_id<<" is the MaJia of "<<s[i].main_id<<endl;
		}
		cout<<endl;

	}

	return 0;
}

  

posted @ 2016-03-23 00:21  日天大哥哥  阅读(344)  评论(0编辑  收藏  举报