poj 2886 线段树+反素数

Who Gets the Most Candies?
Time Limit: 5000MS   Memory Limit: 131072K
Total Submissions: 12744   Accepted: 3968
Case Time Limit: 2000MS

Description

N children are sitting in a circle to play a game.

The children are numbered from 1 to N in clockwise order. Each of them has a card with a non-zero integer on it in his/her hand. The game starts from the K-th child, who tells all the others the integer on his card and jumps out of the circle. The integer on his card tells the next child to jump out. Let A denote the integer. If A is positive, the next child will be the A-th child to the left. If A is negative, the next child will be the (−A)-th child to the right.

The game lasts until all children have jumped out of the circle. During the game, the p-th child jumping out will get F(p) candies where F(p) is the number of positive integers that perfectly divide p. Who gets the most candies?

Input

There are several test cases in the input. Each test case starts with two integers N (0 < N ≤ 500,000) and K (1 ≤ K ≤ N) on the first line. The next N lines contains the names of the children (consisting of at most 10 letters) and the integers (non-zero with magnitudes within 108) on their cards in increasing order of the children’s numbers, a name and an integer separated by a single space in a line with no leading or trailing spaces.

Output

Output one line for each test case containing the name of the luckiest child and the number of candies he/she gets. If ties occur, always choose the child who jumps out of the circle first.

 

Sample Input

4 2
Tom 2
Jack 4
Mary -1
Sam 1

Sample Output

Sam 3


1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
/*
poj 2886 线段树+反素数
反素数:
(1)给定一个数,求一个最小的正整数,使得的约数个数为
(2)求出中约数个数最多的这个数
 
反素数以前也大概学习过,但是做这个题的时候并没有想到优化方法
问题很严重- -
 
给你n个数围成一圈,然后每个人对应一个数字
如果x是正数,则下一个人是左边第x个。如果x为负数,则下一个人是
右边第-x个
 
大致思路是没啥问题,但是开始是将所有数进行预处理,求出第i个数
的f[i],然后同过线段树判断左右两边的剩余人数,然后TLE
 
后来发现别人都是先反素数打表,rprim[0]表示有rprim[1]个因子时的最
大值,然后便能1-n中f[]最大值p的位置。然后只需从1模拟到p求出这时对
应的人即可
 
hhh-2016-03-23 23:50:13
*/
#include <algorithm>
#include <cmath>
#include <queue>
#include <iostream>
#include <cstring>
#include <map>
#include <cstdio>
#include <vector>
#include <functional>
#define lson (i<<1)
#define rson ((i<<1)|1)
using namespace std;
typedef long long ll;
const int maxn = 500550;
int rprim[35][2] =
{
    498960,200,332640,192,277200,180,221760,168,166320,160,
    110880,144,83160,128,55440,120,50400,108,45360,100,
    27720,96,25200,90,20160,84,15120,80,10080,72,
    7560,64,5040,60,2520,48,1680,40,1260,36,
    840,32,720,30,360,24,240,20,180,18,
    120,16,60,12,48,10,36,9,24,8,
    12,6,6,4,4,3,2,2,1,1
};
struct node
{
    int l,r;
    int num;
    int mid()
    {
        return ((l+r)>>1);
    };
} tree[maxn<<2];
 
 
void update_up(int i)
{
    tree[i].num = tree[lson].num + tree[rson].num;
}
 
void build(int i,int l,int r)
{
    tree[i].l = l,tree[i].r = r;
 
    if(l == r)
    {
        tree[i].num = 1;
        return ;
    }
    int mid = tree[i].mid();
    build(lson,l,mid);
    build(rson,mid+1,r);
    update_up(i);
}
 
void update_down(int i)
{
 
}
int cur;
void Insert(int i,int k)
{
    if(tree[i].l ==  tree[i].r)
    {
        cur = tree[i].l;
        tree[i].num = 0;
        return ;
    }
    update_down(i);
    int mid = tree[i].mid();
    if(k <= tree[lson].num)
        Insert(lson,k);
    else
        Insert(rson,k-tree[lson].num);
    update_up(i);
}
 
int query(int i,int l,int r)
{
    if(tree[i].l >= l && tree[i].r <= r)
        return tree[i].num;
    update_down(i);
    int mid = tree[i].mid();
    int all = 0;
    if(l <= mid)
        all += query(lson,l,r);
    if(r > mid)
        all += query(rson,l,r);
    return all;
}
 
char nam[maxn][13];
int a[maxn];
 
int main()
{
    int k,n,t,m,nex;
    while(scanf("%d%d",&n,&k) != EOF)
    {
        t = 0;
        while(n < rprim[t][0])
            t++;
        int x = rprim[t][0];
        for(int i = 1; i <= n; i++)
        {
            scanf("%s%d",nam[i],&a[i]);
        }
        build(1,1,n);
        cur = k,m = n;
        for(int i = 1; i < x; i++)
        {
            //cout << cur << endl;
            Insert(1,cur);
           //cout << cur <<endl;
            nex = a[cur];
            m--;
            if(nex%m == 0)
            {
                if(nex < 0) nex = 1;
                else nex = m;
            }
            else
            {
                nex %= m;
                if(nex < 0) nex += (m+1);
            }
            int leftnum = query(1,1,cur);
            int rightnum = m - leftnum;
            if(nex <= rightnum) cur = leftnum + nex;
            else cur = nex-rightnum;
        }
        Insert(1,cur);
        printf("%s %d\n",nam[cur],rprim[t][1]);
    }
    return 0;
}

  


posted @   Przz  阅读(181)  评论(0编辑  收藏  举报
编辑推荐:
· 现代计算机视觉入门之:什么是图片特征编码
· .NET 9 new features-C#13新的锁类型和语义
· Linux系统下SQL Server数据库镜像配置全流程详解
· 现代计算机视觉入门之:什么是视频
· 你所不知道的 C/C++ 宏知识
阅读排行:
· 不到万不得已,千万不要去外包
· C# WebAPI 插件热插拔(持续更新中)
· 会议真的有必要吗?我们产品开发9年了,但从来没开过会
· 【译】我们最喜欢的2024年的 Visual Studio 新功能
· 如何打造一个高并发系统?
点击右上角即可分享
微信分享提示