L2-013. 红色警报(并查集+无向图联通分量)

战争中保持各个城市间的连通性非常重要。本题要求你编写一个报警程序,当失去一个城市导致国家被分裂为多个无法连通的区域时,就发出红色警报。注意:若该国本来就不完全连通,是分裂的k个区域,而失去一个城市并不改变其他城市之间的连通性,则不要发出警报。

输入格式:

输入在第一行给出两个整数N(0 < N <=500)和M(<=5000),分别为城市个数(于是默认城市从0到N-1编号)和连接两城市的通路条数。随后M行,每行给出一条通路所连接的两个城市的编号,其间以1个空格分隔。在城市信息之后给出被攻占的信息,即一个正整数K和随后的K个被攻占的城市的编号。

注意:输入保证给出的被攻占的城市编号都是合法的且无重复,但并不保证给出的通路没有重复。

输出格式:

对每个被攻占的城市,如果它会改变整个国家的连通性,则输出“Red Alert: City k is lost!”,其中k是该城市的编号;否则只输出“City k is lost.”即可。如果该国失去了最后一个城市,则增加一行输出“Game Over.”。

输入样例:

5 4
0 1
1 3
3 0
0 4
5
1 2 0 4 3

输出样例:

City 1 is lost.
City 2 is lost.
Red Alert: City 0 is lost!
City 4 is lost.
City 3 is lost.
Game Over.
#include<iostream>
#include<vector>
#include<cstdio>
#include<cstring>

using namespace std;

const int N = 500 + 5;

int pre[N], mat[N][N], ext[N];

int n, m;
void Init(){
    for(int i = 0; i < n; i++)
        if(pre[i] >= 0) pre[i] = i;
}

int Find(int x){
    return (pre[x] == x ? x: pre[x] = Find(pre[x]));
}

void Merge(int x, int y){
    x = Find(x); y = Find(y);
    if(x != y) pre[y] = x;
}

int Count(){
    int cnt = 0;
    for(int i = 0; i < n; i++)
        if(pre[i] >= 0 && pre[i] == i) cnt++;
    return cnt;
}
vector<int> Edge[N];

int main(){
    scanf("%d %d", &n, &m);
    memset(pre, 0, sizeof(pre));
    memset(mat, 0, sizeof(mat));
    Init();

    int u, v;

    for(int i = 0; i < m; i++){
        scanf("%d %d", &u, &v);
        if(!mat[u][v]){
            Edge[u].push_back(v);
            Edge[v].push_back(u);
        }
        mat[u][v] = mat[v][u] = true;
        Merge(u, v);
    }

    int tmp = Count();

    scanf("%d", &m);
    for(int k = 0; k < m; k++){
        scanf("%d", &u);
        pre[u] = -1;
        Init();

        for(int i = 0; i < n; i++){
            if(pre[i] < 0) continue;
            for(int j = Edge[i].size() - 1; j >= 0; j--){
                v = Edge[i][j];
                if(pre[v] < 0) continue;
                Merge(i, v);
            }
        }
        int cnt = Count();
        //cout << cnt << endl;
        if(tmp < cnt){
            printf("Red Alert: City %d is lost!\n", u);
        }else printf("City %d is lost.\n", u);
        tmp = cnt;
    }
    if(m == n) {printf("Game Over.\n");}
}

 

posted @ 2018-03-23 19:08  Pretty9  阅读(214)  评论(0编辑  收藏  举报