L2-004. 这是二叉搜索树吗?

一棵二叉搜索树可被递归地定义为具有下列性质的二叉树:对于任一结点,

  • 其左子树中所有结点的键值小于该结点的键值;
  • 其右子树中所有结点的键值大于等于该结点的键值;
  • 其左右子树都是二叉搜索树。

所谓二叉搜索树的“镜像”,即将所有结点的左右子树对换位置后所得到的树。

给定一个整数键值序列,现请你编写程序,判断这是否是对一棵二叉搜索树或其镜像进行前序遍历的结果。

输入格式:

输入的第一行给出正整数N(<=1000)。随后一行给出N个整数键值,其间以空格分隔。

输出格式:

如果输入序列是对一棵二叉搜索树或其镜像进行前序遍历的结果,则首先在一行中输出“YES”,然后在下一行输出该树后序遍历的结果。数字间有1个空格,一行的首尾不得有多余空格。若答案是否,则输出“NO”。

输入样例1:

7
8 6 5 7 10 8 11

输出样例1:

YES
5 7 6 8 11 10 8

输入样例2:

7
8 10 11 8 6 7 5

输出样例2:

YES
11 8 10 7 5 6 8

输入样例3:

7
8 6 8 5 10 9 11

输出样例3:

NO
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<vector>
using namespace std;

const int N = 1000 + 5;

struct node{
    int key;
    struct node *lchild, *rchild;
    node(){
        lchild = rchild = NULL;
    }
};
int n;

vector<int> v;
node *head = NULL;
void creat(node  *&head, int key){
    if(head == NULL){
        head = new node();
        head -> key = key;
        return;
    }else if(key < head -> key){
        creat(head -> lchild, key);
    }else
        creat(head -> rchild, key);
}
vector<int> leaf, ans;

void P_sc_ans(node *head){
    if(head == NULL) return;
    P_sc_ans(head -> lchild);
    P_sc_ans(head -> rchild);
    ans.push_back(head -> key);
}

void P_sc(node *head){
    if(head == NULL) return;
    leaf.push_back(head -> key);
    P_sc(head -> lchild);
    P_sc(head -> rchild);
}

void P_wc(node *head){
    if(head == NULL) return;
    ans.push_back(head -> key);
    P_wc(head -> lchild);
    P_wc(head -> rchild);
    leaf.push_back(head -> key);
}
int main(){
    cin >> n;
    int x;
    for(int i = 0; i < n; i++){
        cin >> x;
        v.push_back(x);
        creat(head, x);
    }
    P_sc(head);
    if(v == leaf){
        printf("YES\n");
        P_sc_ans(head);
        for(int i = 0; i < n; i++)
            printf("%d%c", ans[i], (i != n -1? ' ':'\n'));
            return 0;
    }else{
        leaf.clear();
        P_wc(head);
        reverse(leaf.begin(), leaf.end());
        if(v == leaf){
            printf("YES\n");
            //P_wc_ans(head);
            for(int i = n -1; i >= 0; i--)
                printf("%d%c", ans[i], i?' ':'\n');
                return 0;
        }
    }
    printf("NO\n");
    //print(head);
}

 

posted @ 2018-03-22 14:21  Pretty9  阅读(191)  评论(0编辑  收藏  举报