排序 排序 还是排序

Shopaholic
Time Limit: 3000/1000 MS (Java/Others)   Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 130    Accepted Submission(s): 94

 

Problem Description

Lindsay is a shopaholic. Whenever there is a discount of the kind where you can buy three items and only pay for two, she goes completely mad and feels a need to buy all items in the store. You have given up on curing her for this disease, but try to limit its effect on her wallet. 
You have realized that the stores coming with these offers are quite elective when it comes to which items you get for free; it is always the cheapest ones. As an example, when your friend comes to the counter with seven items, costing 400, 350, 300, 250, 200, 150, and 100 dollars, she will have to pay 1500 dollars. In this case she got a discount of 250 dollars. You realize that if she goes to the counter three times, she might get a bigger discount. E.g. if she goes with the items that costs 400, 300 and 250, she will get a discount of 250 the first round. The next round she brings the item that costs 150 giving no extra discount, but the third round she takes the last items that costs 350, 200 and 100 giving a discount of an additional 100 dollars, adding up to a total discount of 350. 
Your job is to find the maximum discount Lindsay can get. 

Input 
The first line of input gives the number of test scenarios, 1 <= t <= 20. Each scenario consists of two lines of input. The first gives the number of items Lindsay is buying, 1 <= n <= 20000. The next line gives the prices of these items, 1 <= pi <= 20000. 

Output 
For each scenario, output one line giving the maximum discount Lindsay can get by selectively choosing which items she brings to the counter at the same time. 

Sample Input 


400 100 200 350 300 250 

Sample Output 
400 

Source 
2008“网新国际杯”浙江省大学生程序设计竞赛——热身赛(3) 

Recommend 
lcy 


------------------------------------------------------------------------------------------------- 
URL:http://acm.hdu.edu.cn/showproblem.php?pid=1678 

解题思路: 
输入数据->排序->选择出优惠的商品价格(排序后每隔3个为优惠商品的价格)->输出 
考点:排序 
提示:使用快速排序法,否则会超时 

代码: 

#include <stdio.h> 
int partition(int a[],int p1,int p2) 
{ int i,j; 
  int x; 
  i=p1; 
  j=p2; 
  x=*(a+i); 
  while(i<j) 
  { while(*(a+j)>=x&&i<j) j--; 
    if(i<j) 
    { *(a+i)=*(a+j); 
      i++; 
    } 
    while(*(a+i)<x&&i<j) i++; 
    if(i<j) 
    { *(a+j)=*(a+i); 
      j--; 
    } 
  } 
  *(a+i)=x; 
  return(i); 
} 
void sortquick(int a[],int p1,int p2) 
{ int p; 
  if(p1<p2) 
  { p=partition(a,p1,p2); 
    sortquick(a,p1,p-1); 
    sortquick(a,p+1,p2); 
  } 
} 
main() 
{ int t,n,i,j,a[20000]; 
  long s; 
  scanf("%d",&t); 
  for(i=0;i<t;i++) 
  { scanf("%d",&n); 
    for(j=0;j<n;j++) 
      scanf("%d",a+j); 
    sortquick(a,0,n-1); 
    s=0; 
    for(j=n-3;j>=0;j-=3) 
      s+=*(a+j); 
    printf("%ld\n",s); 
  } 
}

 

posted @ 2012-05-10 17:07  陈小怪  阅读(212)  评论(0编辑  收藏  举报