C - Trailing Zeroes (III) LightOJ - 1138

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N. For example, 5! = 120, 120 contains one zero on the trail.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output

For each case, print the case number and N. If no solution is found then print 'impossible'.

Sample Input

3

1

2

5

Sample Output

Case 1: 5

Case 2: 10

Case 3: impossible

 

/*****

思路:对0--5*x进行二分(别问我为什莫,自己好好想想)

*****/

AC:代码

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
ll judge(ll mid,ll n){
	ll s = 0;
	while(mid>=5){
		mid /= 5;
		s += mid;  
	}
	if(s>=n) return 0;
	else return 1;
}
int main()
{
	int t,ncase = 1;
	cin>>t;
	while(t--)
	{
		ll n;
		scanf("%lld",&n);
		ll low = 0,high = 5*n,mid;
		for(int i = 0;i<300;i++){
			mid = low + (high - low)/2;
			if(judge(mid,n)) low = mid + 1;
			else high = mid;
		}
		ll a = low,s = 0;
		while(low>=5){
			low /= 5;
			s += low;
		}
		printf("Case %d: ",ncase++);
		if(s == n){
			printf("%lld\n",a);
		}
		else printf("impossible\n");
	}
	
	return 0;
 } 


posted @ 2018-04-13 10:00  Nlifea  阅读(128)  评论(0编辑  收藏  举报