数型DP

HDU—1520

 

Anniversary party

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15376    Accepted Submission(s): 5925


Problem Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
 

 

Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0
 

 

Output
Output should contain the maximal sum of guests' ratings.
 

 

Sample Input

7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0
 

 

Sample Output

5

//某公司要举办一次晚会,但是为了使得晚会的气氛更加活跃,每个参加晚会的人都不希望在晚会中
//见到他的直接上司,现在已知每个人的活跃指数和上司关系(当然不可能存在环),求邀请哪些人

//(多少人)来能使得晚会的总活跃指数最大。

思路求数的最大独立集

#include<cstdio>
#include<vector>
#include<cstring>
#include<iostream>
#include<algorithm>

using namespace std;
const int maxn = 6005;

vector<int>G[maxn];
int dp[maxn][2],father[maxn];


void tree_dp(int s){
	int l = G[s].size();
	for(int i = 0;i<l;i++){
		tree_dp(G[s][i]);
		dp[s][1] += dp[G[s][i]][0];
		dp[s][0] += max(dp[G[s][i]][0],dp[G[s][i]][1]);
	}
}

int main()
{
	int t,a,b;
	while(~scanf("%d",&t))
	{
		for(int i = 0;i<maxn;i++) G[i].clear();
		memset(dp,0,sizeof(dp));
		memset(father,0,sizeof(father));
		for(int i = 1;i<=t;i++){
			scanf("%d",&dp[i][1]);
		}
		int root = 0;
		while(~scanf("%d %d",&a,&b) && (a+b))
		{
			father[a] = b;
			G[b].push_back(a);
			root = b;
		}
		while(father[root]){
			root = father[root];
		}
		tree_dp(root);
		int maxx = max(dp[root][1],dp[root][0]);
		printf("%d\n",maxx);
	}
	return 0;
}


posted @ 2018-05-13 09:17  Nlifea  阅读(102)  评论(0编辑  收藏  举报