Poj -- 1704 Georgia and Bob (nim)

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 11916   Accepted: 3957

Description

Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, ..., and place N chessmen on different grids, as shown in the following figure for example: 


Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game. 

Georgia always plays first since "Lady first". Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out. 

Given the initial positions of the n chessmen, can you predict who will finally win the game? 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the number of chessmen. The second line contains N different integers P1, P2 ... Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.

Output

For each test case, prints a single line, "Georgia will win", if Georgia will win the game; "Bob will win", if Bob will win the game; otherwise 'Not sure'.

Sample Input

2
3
1 2 3
8
1 5 6 7 9 12 14 17

Sample Output

Bob will win
Georgia will win

思路:

(1),我们首先考虑必败局势,当两个棋子相连是这时先手必败,(如同nim里面,当两堆,石子相等时先手必败策略一样,那么我们可以顺着这个思路考虑下去)。

(2),nim游戏里面最终的策略的答案是ans = a1^a2^a3^......^an。

(3),我们可以将这个游戏模拟成为nim游戏,每一堆的数量为相邻两个棋子之间的距离然后这个问题就完美的解决了。

AC:代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int maxn = 1e4+5;

int v[maxn];

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int ans = 0;
        int n;
        scanf("%d",&n);
        for(int i = 1;i<=n;i++)
        {
            scanf("%d",&v[i]);
        }
        sort(v+1,v+n+1);
        v[0] = 0;
        for(int i = 1;i<=n;i++)
        {
            //((n&1) && (i&1))代表n为奇数时的选则规则,(!(n&1) && !(i&1))代表n为偶数时的选择规则
            if( ((n&1) && (i&1)) || (!(n&1) && !(i&1)) ) ans ^= (v[i] - v[i-1] - 1);
        }
        //printf("%d\n",ans);
        if(ans){
            printf("Georgia will win\n");
        } else {
            printf("Bob will win\n");
        }
    }
    return 0;
}

 

posted @ 2018-06-11 21:24  Nlifea  阅读(111)  评论(0编辑  收藏  举报