Thanks to drizzlecrj's suggestion, I turned to hdu for the primary practice. Hnu was another choice, but the server is too poor that a submitted problem is showed "wariting" all the time.
Problem Description
Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
Input
The input will consist of a series of integers n, one integer per line.
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
Sample Input
1 100
Sample Output
1 5050
#include <stdio.h>
int main()
{
int a = 0, b = 0;
while(scanf("%d", &a) != EOF)
{
b = 0;
int i = 1;
for(; i <= a; i++)
b = b + i;
printf("%d\n\n", b);
}
return 0;
}
Summary:
Easy as it may seem, I am starting off.