D - Common Subsequence

D - Common Subsequence
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0
一定要用记忆化,要不然会超时,还有刚开始数组开的太小了,只开到一百,结果是RE。改到600后就好了。
my answer :
一、记忆化了的。
#include<iostream>
#include<stdio.h>
#include<string>
#include<cstring>
using namespace std;
int main()
{
    char a[600],b[600];
    while(scanf("%s%s",a,b)!=EOF)
    {
        int t1=strlen(a);
        int t2=strlen(b);
        int dp[600][600];
        memset(dp,-1,sizeof(dp));
        for(int i=t1;i>=0;i--)
            a[i+1]=a[i];
        for(int j=t2;j>=0;j--)
            b[j+1]=b[j];
        for(int i=0;i<=t1;i++){
            for(int j=0;j<=t2;j++){
                if(i==0||j==0)dp[i][j]=0;
                else if(a[i]==b[j]&&dp[i][j]<0){dp[i][j]=dp[i-1][j-1]+1;}
                else if(dp[i][j]<0){dp[i][j]=max(dp[i-1][j],dp[i][j-1]);}
                
            }
        }
        printf("%d\n",dp[t1][t2]);
    }
    return 0;
}
别人写的:
进行了空间的优化:
<pre name="code" class="cpp">#include <stdio.h>
#include <string.h>
char s1[1001], s2[1001];
int dp[1001], t, old, tmp;
int main(){
    scanf("%d", &t);
    getchar();
    while(t--){
        gets(s1);
        gets(s2);
        memset(dp, 0, sizeof(dp));
        int lenS1=strlen(s1), lenS2=strlen(s2);
        for(int i=0; i<lenS1; i++){//若s1[i]==s2[j], dp[i][j] = dp[i-1][j-1]+1 否则,dp[i][j] = max(dp[i-1][j], dp[i][j-1])
            old=0;//此处进行了空间优化,old 代表 dp[i-1][j-1] dp[j-1] 代表 dp[i][j-1], dp[j] 代表 dp[i-1][j]
            for(int j=0; j<lenS2; j++){
                tmp = dp[j];
                if(s1[i]==s2[j])
                    dp[j] = old+1;
                else
                    if(dp[j-1]>dp[j])dp[j]=dp[j-1];
                old = tmp;
            }
        }
        printf("%d\n", dp[lenS2-1]);
    }
    return 0;
}        


写的太烂,下面是学姐的代码:


#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
using namespace std;
#define max_n 1000
#define max_m 1000
int dp[max_n][max_m];
char s[max_n],t[max_m];
int main()
{
    while(scanf("%s%s",s,t)!=EOF)
    {
        int n=strlen(s);
        int m=strlen(t);
        memset(dp,0,sizeof(dp));
        for(int i=0;i<n;i++)
    {
        for(int j=0;j<m;j++)
        {
            if(s[i]==t[j])
                dp[i+1][j+1]=dp[i][j]+1;
            else
                dp[i+1][j+1]=max(dp[i][j+1],dp[i+1][j]);
        }
    }
    printf("%d\n",dp[n][m]);
    }
    return 0;
}
再写一个:
试试即记忆化,又空间优化一下:等一会吧。。。。。。让我想想。。。

posted @ 2014-12-15 18:19  NYNU_ACM  阅读(176)  评论(0编辑  收藏  举报