Problem B: Excuses, Excuses!

Problem B: Excuses, Excuses!
Time Limit: 1 Sec Memory Limit: 128 MB
Submit: 4 Solved: 2
[Submit][Status][Web Board]
Description
Judge Ito is having a problem with people subpoenaed for jury duty giving rather lame excuses in order to avoid serving. In order to reduce the amount of time required listening to goofy excuses, Judge Ito has asked that you write a program that will search for a list of keywords in a list of excuses identifying lame excuses. Keywords can be matched in an excuse regardless of case.

Input
Input to your program will consist of multiple sets of data.

Line 1 of each set will contain exactly two integers. The first number ( tex2html_wrap_inline30 ) defines the number of keywords to be used in the search. The second number ( tex2html_wrap_inline32 ) defines the number of excuses in the set to be searched.
Lines 2 through K+1 each contain exactly one keyword.
Lines K+2 through K+1+E each contain exactly one excuse.
All keywords in the keyword list will contain only contiguous lower case alphabetic characters of length L ( tex2html_wrap_inline42 ) and will occupy columns 1 through L in the input line.
All excuses can contain any upper or lower case alphanumeric character, a space, or any of the following punctuation marks [SPMamp".,!?&] not including the square brackets and will not exceed 70 characters in length.
Excuses will contain at least 1 non-space character.

Output
For each input set, you are to print the worst excuse(s) from the list.

The worst excuse(s) is/are defined as the excuse(s) which contains the largest number of incidences of keywords.
If a keyword occurs more than once in an excuse, each occurrance is considered a separate incidence.
A keyword ``occurs" in an excuse if and only if it exists in the string in contiguous form and is delimited by the beginning or end of the line or any non-alphabetic character or a space.
For each set of input, you are to print a single line with the number of the set immediately after the string ``Excuse Set #". (See the Sample Output). The following line(s) is/are to contain the worst excuse(s) one per line exactly as read in. If there is more than one worst excuse, you may print them in any order.

After each set of output, you should print a blank line.

Sample Input
5 3
dog
ate
homework
canary
died
My dog ate my homework.
Can you believe my dog died after eating my canary... AND MY HOMEWORK?
This excuse is so good that it contain 0 keywords.
6 5
superhighway
crazy
thermonuclear
bedroom
war
building
I am having a superhighway built in my bedroom.
I am actually crazy.
1234567890.....,,,,,0987654321?????!!!!!!
There was a thermonuclear war!
I ate my dog, my canary, and my homework ... note outdated keywords?
Sample Output
Excuse Set #1
Can you believe my dog died after eating my canary... AND MY HOMEWORK?

Excuse Set #2
I am having a superhighway built in my bedroom.
There was a thermonuclear war!
my answer:

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<cstring>
#include<cctype>
#include<string>
using namespace std;
void tolow(char s[])
{
    int tt=strlen(s);
    for(int i=0;i!=tt;i++){
        if(s[i]>='A'&&s[i]<='Z')
            s[i]+=32;
    }
}
int id(char a[],char b[])//注意调用函数中a为长串,b为短串;
{
    tolow(a);
    tolow(b);
    int str1=strlen(a);
    int str2=strlen(b);
    int k,count =0;
    for(int i=0;i!=str1;i++){
        k=0;
        for(int j=i;k!=str2;k++,j++)
        {
            if(a[j]!=b[k])
                break;
        }
        if(k>=str2){
            count++;
            break;
        }
    }
    if(count)
        return 1;
    else
        return 0;
}
int main()
{
    int n,m;
    int q=0;
    while(cin>>n>>m)
    {
        q++;
        char b[100][30];
        for(int i=0;i!=n;i++)
            cin>>b[i];
            getchar();
        char a[100][200];
        char aa[100][200];
        for(int j=0;j!=m;j++){
            gets(a[j]);
            strcpy(aa[j],a[j]);
        }
        int f=0,h=0;
        int sum[100]={0};
        for(f=0;f!=m;f++){
            for(h=0;h!=n;h++){
                sum[f]+=id(a[f],b[h]);
            }
        }
        int MAX=0;
        for (int i=0;i!=m;i++)
            if(MAX <sum[i])MAX=sum[i];
        printf("Excuse Set #%d\n",q);
        for(int j=0;j!=m;j++)
            if(MAX==sum[j])
               puts(aa[j]);
        cout<<endl;
 
 
 
    }
    return 0;
}

写完就已经很累了,就不多解释了,注意的有一点就是函数strlwr(字符串大小写转换函数)在linux中是不能用的。。。。坑爹。让我PE了两次。

posted @ 2014-11-18 17:11  NYNU_ACM  阅读(296)  评论(0编辑  收藏  举报