HDU 1533 Going Home

Going Home

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6565    Accepted Submission(s): 3453


Problem Description
On a grid map there are n little men and n houses. In each unit time, every little man can move one unit step, either horizontally, or vertically, to an adjacent point. For each little man, you need to pay a $1 travel fee for every step he moves, until he enters a house. The task is complicated with the restriction that each house can accommodate only one little man. 

Your task is to compute the minimum amount of money you need to pay in order to send these n little men into those n different houses. The input is a map of the scenario, a '.' means an empty space, an 'H' represents a house on that point, and am 'm' indicates there is a little man on that point. 

You can think of each point on the grid map as a quite large square, so it can hold n little men at the same time; also, it is okay if a little man steps on a grid with a house without entering that house.
 

 

Input
There are one or more test cases in the input. Each case starts with a line giving two integers N and M, where N is the number of rows of the map, and M is the number of columns. The rest of the input will be N lines describing the map. You may assume both N and M are between 2 and 100, inclusive. There will be the same number of 'H's and 'm's on the map; and there will be at most 100 houses. Input will terminate with 0 0 for N and M.
 

 

Output
For each test case, output one line with the single integer, which is the minimum amount, in dollars, you need to pay. 
 

 

Sample Input
2 2 .m H. 5 5 HH..m ..... ..... ..... mm..H 7 8 ...H.... ...H.... ...H.... mmmHmmmm ...H.... ...H.... ...H.... 0 0
 

 

Sample Output
2 10 28
此题所求的是最小匹配,建图时将每条边的权值取相反数,然后结果取相反数就ok辣
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <iostream>
using namespace std;
const int N = 310;
const int INF = 0x3f3f3f3f;
int nx,ny;
int g[N][N];
char a[N][N];
int linker[N],lx[N],ly[N];
int slack[N];
bool visx[N],visy[N];
bool DFS(int x)
{
    visx[x]=true;
    for(int y=1; y<=ny; y++)
    {
        if(visy[y])
        {
            continue;
        }
        int tmp=lx[x]+ly[y]-g[x][y];
        if(tmp==0)
        {
            visy[y]=true;
            if(linker[y]==-1||DFS(linker[y]))
            {
                linker[y]=x;
                return true;
            }
        }
        else if(slack[y]>tmp)
        {
            slack[y]=tmp;
        }
    }
    return false;
}
int KM()
{
    memset(linker,-1,sizeof(linker));
    memset(ly,0,sizeof(ly));
    for(int i=1; i<=nx; i++)
    {
        lx[i]=-INF;
        for(int j=1; j<=ny; j++)
        {
            if(g[i][j]>lx[i])
            {
                lx[i]=g[i][j];
            }
        }
    }
    for(int x=1; x<=nx; x++)
    {
        for(int i=1; i<=ny; i++)
        {
            slack[i]=INF;
        }
        while(true)
        {
            memset(visx,false,sizeof(visx));
            memset(visy,false,sizeof(visy));
            if(DFS(x))break;
            int d=INF;
            for(int i=1; i<=ny; i++)
            {
                if(!visy[i]&&d>slack[i])
                {
                    d=slack[i];
                }
            }
            for(int i=1; i<=nx; i++)
            {
                if(visx[i])
                {
                    lx[i]-=d;
                }
            }
            for(int i=1; i<=ny; i++)
            {
                if(visy[i])
                {
                    ly[i]+=d;
                }
                else
                {
                    slack[i]-=d;
                }
            }
        }
    }
    int res=0;
    for(int i=1; i<=ny; i++)
    {
        if(linker[i]!=-1)
        {
            res+=g[linker[i]][i];
        }
    }
    return res;
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m)&&n&&m)
    {
        for(int i=0; i<n; i++)
        {
            scanf("%s",a[i]);
        }
        int x=0,y=0;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                if(a[i][j]=='m')
                {
                    x++;
                    for(int k=0;k<n;k++)
                    {
                        for(int kk=0;kk<m;kk++)
                        {
                            if(a[k][kk]=='H')
                            {
                                g[x][++y]=-(abs(i-k)+abs(j-kk));
                            }
                        }
                    }
                    y=0;
                }
            }
        }
        nx=ny=x;
        printf("%d\n",- KM());
    }
    return 0;
}
View Code

 

posted @ 2018-08-03 19:57  NBLX_QAQ  阅读(86)  评论(0编辑  收藏  举报