POJ 3468 A Simple Problem with Integers

Time Limit: 5000MS   Memory Limit: 131072K
Total Submissions: 129964   Accepted: 40362
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source

线段树区间更新及查询
#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;
#define ll long long
int ans;
ll sum[400100],add[400100];
struct node
{
    int l,r;
    int mid()
    {
        return (l+r)>>1;
    }
}s[400010];
void pushup(int rt)
{
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void pushdown(int rt,int m)
{
    if(add[rt])
    {
        add[rt<<1]+=add[rt];
        add[rt<<1|1]+=add[rt];
        sum[rt<<1]+=add[rt]*(m-(m>>1));
        sum[rt<<1|1]+=add[rt]*(m>>1);
        add[rt]=0;
    }
}
void build(int l,int r,int rt)
{
    s[rt].l=l;
    s[rt].r=r;
    add[rt]=0;
    if(r==l)
    {
        scanf("%lld",&sum[rt]);
        return ;
    }
    int m=s[rt].mid();
    build(l,m,rt<<1);
    build(m+1,r,rt<<1|1);
    pushup(rt);
}
void update(int z,int l,int r,int rt)
{
    if(s[rt].l==l&&s[rt].r==r)
    {
        add[rt]+=z;
        sum[rt]+=z*(r-l+1);
        return ;
    }
    if(s[rt].l==s[rt].r)
    {
        return ;
    }
    pushdown(rt,s[rt].r-s[rt].l+1);
    int m=s[rt].mid();
    if(r<=m)
    {
        update(z,l,r,rt<<1);
    }
    else if(l>m)
    {
        update(z,l,r,rt<<1|1);
    }
    else
    {
        update(z,l,m,rt<<1);
        update(z,m+1,r,rt<<1|1);
    }
    pushup(rt);
}
ll qurey(int l,int r,int rt)
{
    if(s[rt].l==l&&s[rt].r==r)
    {
        return sum[rt];
    }
    pushdown(rt,s[rt].r-s[rt].l+1);
    int m=s[rt].mid();
    ll res=0;
    if(r<=m)
    {
        res+=qurey(l,r,rt<<1);
    }
    else if(l>m)
    {
        res+=qurey(l,r,rt<<1|1);
    }
    else
    {
        res+=qurey(l,m,rt<<1);
        res+=qurey(m+1,r,rt<<1|1);
    }
    return res;
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        build(1,n,1);
        while(m--)
        {
            char s[10];
            scanf("%s",s);
            int x,y,z;
            if(s[0]=='Q')
            {
                scanf("%d%d",&x,&y);
                printf("%lld\n",qurey(x,y,1));
            }
            else if(s[0]=='C')
            {
                scanf("%d%d%d",&x,&y,&z);
                update(z,x,y,1);
            }
        }
    }
}
View Code

 

posted @ 2018-05-06 15:09  NBLX_QAQ  阅读(77)  评论(0编辑  收藏  举报