HDU 4355 Party All the Time

Party All the Time

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5939    Accepted Submission(s): 1857


Problem Description
In the Dark forest, there is a Fairy kingdom where all the spirits will go together and Celebrate the harvest every year. But there is one thing you may not know that they hate walking so much that they would prefer to stay at home if they need to walk a long way.According to our observation,a spirit weighing W will increase its unhappyness for S3*W units if it walks a distance of S kilometers. 
Now give you every spirit's weight and location,find the best place to celebrate the harvest which make the sum of unhappyness of every spirit the least.
 

 

Input
The first line of the input is the number T(T<=20), which is the number of cases followed. The first line of each case consists of one integer N(1<=N<=50000), indicating the number of spirits. Then comes N lines in the order that x[i]<=x[i+1] for all i(1<=i<N). The i-th line contains two real number : Xi,Wi, representing the location and the weight of the i-th spirit. ( |xi|<=106, 0<wi<15 )
 

 

Output
For each test case, please output a line which is "Case #X: Y", X means the number of the test case and Y means the minimum sum of unhappyness which is rounded to the nearest integer.
 

 

Sample Input
1 4 0.6 5 3.9 10 5.1 7 8.4 10
 

 

Sample Output
Case #1: 832
 

 

Author
Enterpaise@UESTC_Goldfinger
 

 

Source
 
#include <bits/stdc++.h>
using namespace std;
#define eqs 0.000001
struct pap
{
    double x,y;
} a[50005];
int n;
double pansum(double k)
{
    double sum=0;
    for(int i=0; i<n; i++)
    {
        if(k-a[i].x<0)
        {
            sum+=(a[i].x-k)*(a[i].x-k)*(a[i].x-k)*a[i].y;
        }
        else
        {
            sum+=(k-a[i].x)*(k-a[i].x)*(k-a[i].x)*a[i].y;
        }
    }
    return sum;
}
double pan(double l,double r)
{
    while(r-l>eqs)
    {
        double ml=l+(r-l)/3.0;
        double mr=r-(r-l)/3.0;
        if(pansum(ml)<pansum(mr))
        {
            r=mr;
        }
        else
        {
            l=ml;
        }
    }
    return pansum(l);
}
int main()
{
    int t,k=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=0; i<n; i++)
        {
            scanf("%lf%lf",&a[i].x,&a[i].y);
        }
        printf("Case #%d: %.f\n",k++,pan(a[0].x,a[n-1].x));
    }
}
View Code

 

posted @ 2018-04-23 17:38  NBLX_QAQ  阅读(130)  评论(0编辑  收藏  举报