HDU 1711 Number Sequence

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 34621    Accepted Submission(s): 14394


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

 

Sample Input
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

 

Sample Output
6 -1
 

 

Source
 

 

Recommend
lcy
#include <bits/stdc++.h>
using namespace std;
int S[1000005];
int T[10005];
int sss[100005];
int n,m;
void getsss(int n,int m)
{
    int j=0,k=-1;
    sss[0]=-1;
    while(j<m)
    {
        if(k==-1||T[j]==T[k])
        {
            sss[++j]=++k;
        }
        else
        {
            k=sss[k];
        }
    }
}
int kmp(int n,int m)
{
    int i=0,j=0;
    getsss(n,m);
    while(i<n&&j<m)
    {
        if(j==-1||S[i]==T[j])
        {
            i++;
            j++;
        }
        else
        {
            j=sss[j];
        }
    }
    if(j==m)
    {
        return i-m;
    }
    else
    {
        return -1;
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=0; i<n; i++)
        {
            scanf("%d",&S[i]);
        }
        for(int i=0; i<m; i++)
        {
            scanf("%d",&T[i]);
        }
        int ma=kmp(n,m);
        if(ma==-1)
        {
            printf("%d\n",ma);
        }
        else
        {
            printf("%d\n",ma+1);
        }
    }
    return 0;
}
View Code

 

posted @ 2018-03-29 15:08  NBLX_QAQ  阅读(98)  评论(0编辑  收藏  举报