POJ3071 Football 【概率dp】

题目

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

输入格式

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all i ≠ j, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

输出格式

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

输入样例

Language:
Football
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6356 Accepted: 3245
Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all i ≠ j, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

输出样例

2

提示

In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this case is:

P(2 wins) = P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)
= p21p34p23 + p21p43p24
= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.
The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.

题解

简单来说就是一个淘汰制赛制,给出每对选手之间的胜率,求胜率最大的选手
我们令\(f[i][j]\)表示i号选手,第j轮获胜的概率
第j轮要获胜,首先第j - 1轮要获胜,还要击败第j轮的对手
那么就有\(f[i][j] = f[i]][j - 1] * \sum_{k \in opposite} win[i][k] * f[k][j - 1]\)
每次只需枚举区间内的对手累加概率就好了
\(O(n^3)\)

#include<iostream>
#include<cmath>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define LL long long int
#define REP(i,n) for (int i = 1; i <= (n); i++)
#define Redge(u) for (int k = h[u],to; k; k = ed[k].nxt)
#define BUG(s,n) for (int i = 1; i <= (n); i++) cout<<s[i]<<' '; puts("");
using namespace std;
const int maxn = 1 << 8,maxm = 100005,INF = 1000000000;
double f[maxn][10];
double win[maxn][maxn];
int n,m;
int main(){
	while (~scanf("%d",&m) && m >= 0){
		n = 1 << m;
		for (int i = 0; i < n; i++)
			for (int j = 0; j < n; j++)
				scanf("%lf",&win[i][j]);
		for (int i = 0; i < n; i++) f[i][0] = 1.0;
		for (int j = 1; j <= m; j++){
			for (int i = 0; i < n; i++){
				f[i][j] = 0;
				int b = i / (1 << j - 1),op = b ^ 1;
				//printf("round %d  id: %d block: %d\n",j,i,b);
				for (int k = op * (1 << j - 1); k / (1 << j - 1) == op; k++)
					f[i][j] += win[i][k] * f[k][j - 1];
				f[i][j] *= f[i][j - 1];
			}
		}
		int ans = 0;
		for (int i = 1; i < n; i++) if (f[i][m] > f[ans][m]) ans = i;
		//REP(i,n) printf("%.2lf ",f[i - 1][m]); puts("");
		printf("%d\n",ans + 1);
	}
	return 0;
}

posted @ 2018-02-03 10:18  Mychael  阅读(222)  评论(0编辑  收藏  举报