HDU 1285 确定比赛名次

确定比赛名次

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13403    Accepted Submission(s): 5361

Problem Description
有N个比赛队(1<=N<=500),编号依次为1,2,3,。。。。,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前。现在请你编程序确定排名。
 
Input
输入有若干组,每组中的第一行为二个数N(1<=N<=500),M;其中N表示队伍的个数,M表示接着有M行的输入数据。接下来的M行数据中,每行也有两个整数P1,P2表示即P1队赢了P2队。
 
Output
给出一个符合要求的排名。输出时队伍号之间有空格,最后一名后面没有空格。
其他说明:符合条件的排名可能不是唯一的,此时要求输出时编号小的队伍在前;输入数据保证是正确的,即输入数据确保一定能有一个符合要求的排名。
 
Sample Input
4 3
1 2
2 3
4 3
 
Sample Output
1 2 4 3
 
Author
SmallBeer(CML)
 
Source
 
 
Source Code:
#include <cstdio>
#include <queue>
#include <vector>

using namespace std;

priority_queue<int,vector<int>,greater<int> >Q;    //建立一个小顶堆
vector<int> Relationship[510];
int inDegree[510];
vector<int> answer;

void init(int length){
    for(int i=1;i<=length;++i)
        inDegree[i]=0;
    for(int j=1;j<=length;++j)
        Relationship[j].clear();
    while(Q.empty()==false)
        Q.pop();
}

void TopoSort(int N){
    answer.clear();
    for(int i=1;i<=N;++i){
        if(inDegree[i]==0)
            Q.push(i);
    }
    while(Q.empty()==false){
        int nowP=Q.top();
        Q.pop();        //要在下面push之前pop
        for(int j=0;j<Relationship[nowP].size();++j){
            --inDegree[Relationship[nowP][j]];
            if(inDegree[Relationship[nowP][j]]==0)
                Q.push(Relationship[nowP][j]);
        }
        answer.push_back(nowP);
    }
}

void printAnswer(){
    vector<int>::iterator iter;
    bool isFirst=true;
    for(iter=answer.begin();iter!=answer.end();++iter){
        if(isFirst){
            printf("%d",*iter);
            isFirst=false;
        }else{
            printf(" %d",*iter);
        }
    }
    printf("\n");
}

int main(){
    int N,M;
    while(scanf("%d%d",&N,&M)!=EOF){
        init(N);
        int a,b;
        for(int i=0;i<M;++i){
            scanf("%d%d",&a,&b);
            ++inDegree[b];
            Relationship[a].push_back(b);
        }
        TopoSort(N);
        printAnswer();
    }
    return 0;
}

 

posted @ 2015-01-23 15:53  tinylcy  阅读(155)  评论(0编辑  收藏  举报