简单题:暴力计算 32Ms

DNA Sorting
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 50312   Accepted: 19682

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6

AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

 

下面贴代码:

#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
typedef struct
{
   string str;
   int num; //逆序数
}Node;

int cmp(Node a, Node b) //sort 的比较函数
{
   return a.num < b.num;
}

int main()
{
   int n, m, i, sum;
   Node node[100];
   while(scanf("%d", &n) != EOF) //控制输入
   {
      scanf("%d", &m);
      for(i = 0; i < m; i ++)
         cin >> node[i].str;
      for(i = 0; i < m; i ++)
      {
         sum = 0;
         for(int j = 0; j < n; j ++)
         {
            for(int k = j + 1; k < n; k ++)  //计算逆序数
            {
               if(node[i].str[j] > node[i].str[k])
                  sum ++;
            }
         }
         node[i].num = sum;
      }
      sort(node, node + m, cmp);  //排序
      for(i = 0; i < m; i ++)     //输出
       cout << node[i].str << endl;
   }
   return 0;
}

 

posted on 2010-11-25 13:46  00Prince || Lai00  阅读(1021)  评论(2编辑  收藏  举报