Description

We all love recursion! Don't we?

Consider a three-parameter recursive function w(a, b, c):

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.

Input

The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.

Output

Print the value for w(a,b,c) for each triple.

Sample Input

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1

Sample Output

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1

递归问题,但是单纯的照着题目说的写的话,会在50 50 50时候出现超时,所以用到了记忆化深度搜索,以减少重复次数

#include <iostream>
#include <string.h>
using namespace std;
int w[21][21][21]={0};
int cal(int a,int b,int c)
{
    if(a<=0||b<=0||c<=0)
        return 1;
    if(a>20||b>20||c>20)
        return cal(20,20,20);
    if(w[a][b][c]!=0)
        return w[a][b][c];
    if(a<b&&b<c)
       return w[a][b][c]=cal(a,b,c-1)+cal(a,b-1,c-1)-cal(a,b-1,c);
    else
        return w[a][b][c]=cal(a-1,b,c)+cal(a-1,b-1,c)+cal(a-1,b,c-1)-cal(a-1,b-1,c-1);
}
int main()
{
    int a,b,c;
    while(cin>>a>>b>>c)
    {
        memset(w,0,sizeof(w));
        if(a==-1&&b==-1&&c==-1)
            break;
        int result=cal(a,b,c);
        cout<<"w("<<a<<", "<<b<<", "<<c<<") = "<<result<<endl;
    }
    return 0;
}

posted on 2014-09-27 09:30  星斗万千  阅读(108)  评论(0编辑  收藏  举报