Description

Farmer John recently bought another bookshelf for the cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

FJ has N cows (1 ≤ N ≤ 20) each with some height of Hi (1 ≤ Hi ≤ 1,000,000 - these are very tall cows). The bookshelf has a height of B (1 ≤ B ≤ S, where S is the sum of the heights of all cows).

To reach the top of the bookshelf, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf in order for the cows to reach the top.

Since a taller stack of cows than necessary can be dangerous, your job is to find the set of cows that produces a stack of the smallest height possible such that the stack can reach the bookshelf. Your program should print the minimal 'excess' height between the optimal stack of cows and the bookshelf.

Input

* Line 1: Two space-separated integers: N and B
* Lines 2..N+1: Line i+1 contains a single integer: Hi

Output

* Line 1: A single integer representing the (non-negative) difference between the total height of the optimal set of cows and the height of the shelf.

Sample Input

5 16
3
1
3
5
6

Sample Output

1

描述:1、总高度不应小于书架高度。
             2、求最小高度。
             3、输出的是最小高度与书架高度的差。
此题利用0-1背包求,求出所有的取值可能,然后再枚举求解。
#include <iostream>
#include <math.h>
using namespace std;
int H[21],dp[10000000];
int main()
{
    int N,B,i,j,sum=0;
    cin>>N>>B;
    for(i=0;i<N;i++)
    {
        cin>>H[i];
        sum=sum+H[i];
    }
    for(i=0;i<=sum;i++)
        dp[i]=0;
    for(i=0;i<N;i++)
        for(j=sum;j>=H[i];j--)
          dp[j]=max(dp[j-H[i]]+H[i],dp[j]);
    int min1=100000000;
    for(i=0;i<=sum;i++)
    {
        if(dp[i]>=B)
            min1=min(min1,dp[i]);
    }
    cout<<min1-B<<endl;
    return 0;
}




   

posted on 2014-09-27 13:00  星斗万千  阅读(131)  评论(0编辑  收藏  举报