Description

You have to cut a wood stick into pieces. The most affordable company, The Analog Cutting Machinery, Inc. (ACM), charges money according to the length of the stick being cut. Their procedure of work requires that they only make one cut at a time.

It is easy to notice that different selections in the order of cutting can led to different prices. For example, consider a stick of length 10 meters that has to be cut at 2, 4 and 7 meters from one end. There are several choices. One can be cutting first at 2, then at 4, then at 7. This leads to a price of 10 + 8 + 6 = 24 because the first stick was of 10 meters, the resulting of 8 and the last one of 6. Another choice could be cutting at 4, then at 2, then at 7. This would lead to a price of 10 + 4 + 6 = 20, which is a better price.

Your boss trusts your computer abilities to find out the minimum cost for cutting a given stick.

Input 

The input will consist of several input cases. The first line of each test case will contain a positive numberl that represents the length of the stick to be cut. You can assume l < 1000. The next line will contain the number n ( n < 50) of cuts to be made.

The next line consists of n positive numbers ci ( 0 <ci < l) representing the places where the cuts have to be done, given in strictly increasing order.

An input case with l = 0 will represent the end of the input.

Output 

You have to print the cost of the optimal solution of the cutting problem, that is the minimum cost of cutting the given stick. Format the output as shown below.

Sample Input 

100
3
25 50 75
10
4
4 5 7 8
0

Sample Output 

The minimum cutting is 200.
The minimum cutting is 22.




[解题方法]
记忆化搜索(递归,子问题的结果用备忘录存起来,避免重复求解)
设棍子长度n,输入的c[i]是棍子上的坐标
dp[x][y](即dfs(x,y))表示砍c[x]到c[y]段的最小花费
每次砍c[x]~c[y]段的时候枚举砍的位置i
状态转移:dp[x][y] = min(dp[x][i] + dp[i][y] + c[y]-c[x])(x<=i<=y)
注:-1表示无穷大

之所以要加上a[j]-a[i],是要加上当前切割的决策的费用。
注意初始化问题,dp[i][i+1]=0,
也就是这些本身就是现成的小段,不能继续分割,决策费用也为0,总费用为0。


#include <iostream>
#include <string.h>
using namespace std;
int dp[55][55],c[55];
int DFS(int x,int y)
{
    if(dp[x][y]!=-1)
        return dp[x][y];
    int mins=9999999999,i;
    for(i=x+1;i<y;i++)
    {
        int temp=DFS(x,i)+DFS(i,y)+c[y]-c[x];
        if(temp<mins)
            mins=temp;
    }
    return (dp[x][y]=mins);
}

int main()
{
    int len,n,i;
    while(cin>>len&&len!=0)
    {
        cin>>n;
        for(i=1;i<=n;i++)
            cin>>c[i];
        c[0]=0;
        c[n+1]=len;
        memset(dp,-1,sizeof(dp));
        for(i=0;i<=n;i++)
            dp[i][i+1]=0;
        cout<<"The minimum cutting is "<<DFS(0,n+1)<<"."<<endl;
    }
    return 0;
}

posted on 2014-10-09 18:46  星斗万千  阅读(104)  评论(0编辑  收藏  举报