Description

Bob and Alice started to use a brand-new encoding scheme. Surprisingly it is not a Public Key Cryptosystem, but their encoding and decoding is based on secret keys. They chose the secret key at their last meeting in Philadelphia on February 16th, 1996. They chose as a secret key a sequence of n distinct integers, a1 ; . . .; an, greater than zero and less or equal to n. The encoding is based on the following principle. The message is written down below the key, so that characters in the message and numbers in the key are correspondingly aligned. Character in the message at the position i is written in the encoded message at the position ai, where ai is the corresponding number in the key. And then the encoded message is encoded in the same way. This process is repeated k times. After kth encoding they exchange their message.

The length of the message is always less or equal than n. If the message is shorter than n, then spaces are added to the end of the message to get the message with the length n.

Help Alice and Bob and write program which reads the key and then a sequence of pairs consisting of k and message to be encoded k times and produces a list of encoded messages.

Input

The input file consists of several blocks. Each block has a number 0 < n <= 200 in the first line. The next line contains a sequence of n numbers pairwise distinct and each greater than zero and less or equal than n. Next lines contain integer number k and one message of ascii characters separated by one space. The lines are ended with eol, this eol does not belong to the message. The block ends with the separate line with the number 0. After the last block there is in separate line the number 0.

Output

Output is divided into blocks corresponding to the input blocks. Each block contains the encoded input messages in the same order as in input file. Each encoded message in the output file has the lenght n. After each block there is one empty line.

Sample Input

10
4 5 3 7 2 8 1 6 10 9
1 Hello Bob
1995 CERC
0
0

Sample Output

BolHeol  b
C RCE

说下题目大意。首先输入长度为n的数字串,设为key[i],表示第i个字符置换一次后跑到key[i]的位置。然后输入若干字符序列,设字符序列为Src(若长度不足n则后面用空格补齐),求Src中的每个字符进行m次置换后的字符序列Dst。
加密方式如题中所给:
1 2 3 4 5 6 7 8 9 10
4 5 3 7 2 8 1 6 10 9
对于第一个字符,加密3次的结果如下:
1 --> 4 --> 7 -->1
对于第二个字符,加密2次的结果如下:
2 --> 5 --> 2
可以看到,加密一定次数后,结果会构成一个循环,如果我们求出这个循环周期,那么加密的次数就可以使用取余运算进行缩减了。
#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
int n,key[210],t[210];
void convert()
{
    int i,j,count;
    for(i=1;i<=n;i++)
    {
        j=key[i];
        count=1;
        while(i!=j)
        {
            j=key[j];
            count++;
        }
        t[i]=count;
    }
}
int main()
{
    int cases=0;
    while(cin>>n&&n!=0)
    {
        if(cases!=0)
            cout<<endl;
        int i,k;
        memset(key,0,sizeof(key));
        memset(t,0,sizeof(t));
        for(i=1;i<=n;i++)
            cin>>key[i];
        convert();
        while(cin>>k&&k!=0)
        {
            getchar();
            char s1[210],s2[210];
            gets(s1+1);
            memset(s2,' ',sizeof(s2));
            for(i=1;i<strlen(s1);i++)
            {
                int pos=i;
                for(int j=1;j<=k%t[i];j++)
                    pos=key[pos];
                s2[pos]=s1[i];
            }
            for(i=1;i<=n;i++)
                cout<<s2[i];
            cout<<endl;
        }
        cases++;
    }
    return 0;
}
posted on 2014-12-04 17:44  星斗万千  阅读(130)  评论(0编辑  收藏  举报