Description

  Yesterday your dear cousin Coach Pang gave you a new 100MB hard disk drive (HDD) as a gift because you will get married next year.
  But you turned on your computer and the operating system (OS) told you the HDD is about 95MB. The 5MB of space is missing. It is known that the HDD manufacturers have a different capacity measurement. The manufacturers think 1 “kilo” is 1000 but the OS thinks that is 1024. There are several descriptions of the size of an HDD. They are byte, kilobyte, megabyte, gigabyte, terabyte, petabyte, exabyte, zetabyte and yottabyte. Each one equals a “kilo” of the previous one. For example 1 gigabyte is 1 “kilo” megabytes.
  Now you know the size of a hard disk represented by manufacturers and you want to calculate the percentage of the “missing part”.
 

Input

  The first line contains an integer T, which indicates the number of test cases.
  For each test case, there is one line contains a string in format “number[unit]” where number is a positive integer within [1, 1000] and unit is the description of size which could be “B”, “KB”, “MB”, “GB”, “TB”, “PB”, “EB”, “ZB”, “YB” in short respectively.
 

Output

  For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the percentage of the “missing part”. The answer should be rounded to two digits after the decimal point.
 

Sample Input

2 100[MB] 1[B]
 

Sample Output

Case #1: 4.63% Case #2: 0.00%

Hint


#include <iostream>
#include <math.h>
#include <iomanip>
#include <string.h>
using namespace std;
int step(char c)
{
   switch (c)
   {
       case 'B':return 0;
       case 'K':return 1;
       case 'M':return 2;
       case 'G':return 3;
       case 'T':return 4;
       case 'P':return 5;
       case 'E':return 6;
       case 'Z':return 7;
       case 'Y':return 8;
   }
}
int main()
{
    int T,cases=1,i;
    cin>>T;
    while(T--)
    {
        char num[10];
        cin>>num;
        for(i=0;num[i]!='[';i++)
            ;
        int s=step(num[i+1]);
        cout<<"Case #"<<cases++<<": ";
        cout<<setiosflags(ios::fixed)<<setprecision(2);
        cout<<(1- pow(1000.0,s)/pow(1024.0,s))*100<<"%"<<endl;
    }
    return 0;
}
posted on 2014-12-11 18:20  星斗万千  阅读(175)  评论(0编辑  收藏  举报