Description

X soldiers from the famous " *FFF* army" is standing in a line, from left to right. 
You, as the captain of *FFF*, decides to have a "number off", that is, each soldier, from left to right, calls out a number. The first soldier should call "One", each other soldier should call the number next to the number called out by the soldier on his left side. If every soldier has done it right, they will call out the numbers from 1 to X, one by one, from left to right. 
Now we have a continuous part from the original line. There are N soldiers in the part. So in another word, we have the soldiers whose id are between A and A+N-1 (1 <= A <= A+N-1 <= X). However, we don't know the exactly value of A, but we are sure the soldiers stands continuously in the original line, from left to right. 
We are sure among those N soldiers, exactly one soldier has made a mistake. Your task is to find that soldier.
 

Input

The rst line has a number T (T <= 10) , indicating the number of test cases. 
For each test case there are two lines. First line has the number N, and the second line has N numbers, as described above. (3 <= N <= 105
It guaranteed that there is exactly one soldier who has made the mistake.
 

Output

For test case X, output in the form of "Case #X: L", L here means the position of soldier among the N soldiers counted from left to right based on 1.
 

Sample Input

2 3 1 2 4 3 1001 1002 1004
 

Sample Output

Case #1: 3 Case #2: 3
 
#include <cstdio>
#include <cstring>
#include <iostream>
#include <string>
#include <algorithm>
#include <map>
#include <vector>
using namespace std;
int a[100010];
int main()
{
    int t,cnt=1;
    cin>>t;
    while(t--)
    {
        int n;
        cin>>n;
        for(int i=0;i<n;i++)
            cin>>a[i];
        bool f=false;
        for(int i=1;i<n;i++)
        {
            if(a[i]!=a[i-1]+1)
            {
                cout<<"Case #"<<cnt++<<": "<<i+1<<endl;
                f=true;
                break;
            }
        }
        if(!f)
        {
            cout<<"Case #"<<cnt++<<": "<<1<<endl;
        }
    }
    return 0;
}

posted on 2015-05-07 15:28  星斗万千  阅读(108)  评论(0编辑  收藏  举报