Description

In this problem we talk about the study of Computer Graphics. Of course, this is very, very hard. 
We have designed a new mobile phone, your task is to write a interface to display battery powers. 
Here we use '.' as empty grids. 
When the battery is empty, the interface will look like this: 
*------------*
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
|............|
*------------*

When the battery is 60% full, the interface will look like this: 
*------------*
|............|
|............|
|............|
|............|
|------------|
|------------|
|------------|
|------------|
|------------|
|------------|
*------------*

Each line there are 14 characters. 
Given the battery power the mobile phone left, say x%, your task is to output the corresponding interface. Here x will always be a multiple of 10, and never exceeds 100.
 

Input

The first line has a number T (T < 10) , indicating the number of test cases. 
For each test case there is a single line with a number x. (0 < x < 100, x is a multiple of 10)
 

Output

For test case X, output "Case #X:" at the first line. Then output the corresponding interface. 
See sample output for more details.
 

Sample Input

2 0 60
 

Sample Output

Case #1: *------------* |............| |............| |............| |............| |............| |............| |............| |............| |............| |............| *------------* Case #2: *------------* |............| |............| |............| |............| |------------| |------------| |------------| |------------| |------------| |------------| *------------*
#include <iostream>
using namespace std;

int main()
{
    int T,cases=1;
    cin>>T;
    while(T--)
    {
        int N;
        cin>>N;
        cout<<"Case #"<<cases++<<":"<<endl;
        cout<<"*------------*"<<endl;
        for(int i=100;i>N;i=i-10)
            cout<<"|............|"<<endl;
        for(int i=N;i>=10;i=i-10)
            cout<<"|------------|"<<endl;
        cout<<"*------------*"<<endl;
    }
    return 0;
}



posted on 2015-05-07 15:39  星斗万千  阅读(155)  评论(0编辑  收藏  举报