MiYu原创, 转帖请注明 : 转载自 ______________白白の屋    

 

题目地址:

http://acm.hdu.edu.cn/showproblem.php?pid=1157 

题目描述:

Who's in the Middle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2451    Accepted Submission(s): 1204


Problem Description
FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less. 

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
 

Input
* Line 1: A single integer N 

* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.
 

Output
* Line 1: A single integer that is the median milk output.
 

Sample Input
5 2 4 1 3 5
 

Sample Output
3
Hint
INPUT DETAILS: Five cows with milk outputs of 1..5 OUTPUT DETAILS: 1 and 2 are below 3; 4 and 5 are above 3.
 

 

水题,  直接代码 :

 

/*

MiYuÔ­´´, תÌûÇë×¢Ã÷ : תÔØ×Ô ______________°×°×¤ÎÎÝ

          http://www.cnblog.com/MiYu

Author By : MiYu

Test      : 1

Program   : 1157

*/


#include <iostream>

#include <algorithm>

using namespace std;           

int cow[10010];

int main ()

{

    int N;

    while ( cin >> N ){

           for ( int i = 0; i < N; ++ i ) cin >> cow[i];

           sort ( cow, cow + N );      

           cout << cow[N/2] << endl;

    }

    return 0;

}


 

 

 

 posted on 2010-09-04 22:38  MiYu  阅读(414)  评论(0编辑  收藏  举报