P1546 最短网络 Agri-Net

题目背景

农民约翰被选为他们镇的镇长!他其中一个竞选承诺就是在镇上建立起互联网,并连接到所有的农场。当然,他需要你的帮助。

题目描述

约翰已经给他的农场安排了一条高速的网络线路,他想把这条线路共享给其他农场。为了用最小的消费,他想铺设最短的光纤去连接所有的农场。

你将得到一份各农场之间连接费用的列表,你必须找出能连接所有农场并所用光纤最短的方案。每两个农场间的距离不会超过100000

输入输出格式

输入格式:

 

第一行: 农场的个数,N(3<=N<=100)。

第二行..结尾: 后来的行包含了一个N*N的矩阵,表示每个农场之间的距离。理论上,他们是N行,每行由N个用空格分隔的数组成,实际上,他们限制在80个字符,因此,某些行会紧接着另一些行。当然,对角线将会是0,因为不会有线路从第i个农场到它本身。

 

输出格式:

 

只有一个输出,其中包含连接到每个农场的光纤的最小长度。

 

输入输出样例

输入样例#1: 复制
4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0
输出样例#1: 复制
28

说明

题目翻译来自NOCOW。

USACO Training Section 3.1

 

并查集。

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
using namespace std;

int m,n,fa[10002],tot,sum,ans;

struct node
{
	int x,y,z;
}a[10002];

bool cmp(node a,node b)
{
	return a.z <b.z ;
}

int find(int x)
{
	if(fa[x]==x) return x;
	else return fa[x]=find(fa[x]);
}

int main()
{
	int q;
	scanf("%d",&n);
	for(int i=1;i<=n;++i) 
		fa[i]=i;
	for(int i=1;i<=n;++i)
		for(int j=1;j<=n;++j)
		{
			scanf("%d",&q);
			if(q!=0)
			{
				++tot;
				a[tot].x =i;
				a[tot].y =j;
				a[tot].z =q;
			}										
		}
	sort(a+1,a+tot+1,cmp);
	for(int i=1;i<=tot;++i)
	{
		int dx=find(a[i].x ),dy=find(a[i].y );
		if(dx==dy) continue;
		else fa[dy]=dx;
		ans+=a[i].z ;
	}
	printf("%d",ans);
	return 0;
}

  

posted @ 2018-05-23 20:29  孟东行#  阅读(111)  评论(0编辑  收藏  举报